MBP w/ Leopard crashes in sleep

jeremyschultz

macrumors member
Original poster
Nov 2, 2006
54
20
Clive, Iowa USA
I installed Leopard a few days ago on my MBP C2D and twice I've seen my computer crash during sleep. I put it to sleep and go do something else, and when I return it looks like it's not running—sleep light is off, the only thing noticeable is the fan running very quietly. It does not respond to the keyboard or power switch for about a minute, and then I'm able to force shut down with the power switch and reboot.

It doesn't always do this, just twice so far. I wondered if anyone else has heard of this happening.
 

killerrobot

macrumors 68020
Jun 7, 2007
2,220
2
127.0.0.1
Just happened to my 2.33 MBP C2D this morning. The airport caused a kernel panic after waking from sleep and had to hard power-down.
I hope it never happens agains.:(
 
Comment

PeteSamson

macrumors newbie
Nov 13, 2007
1
0
Same thing

I got the same thing twice last night and its getting worse. I left my laptop open running. Nothing to extreme running, I believe I left word, safari, adium, ichat, maybe itunes and azureus running. The only active app being active was azureus. So I went out last night for a few hours came back, same style crash. Turned back on resumed work normally, fell asleep watching a movie on it, woke up, crashed.
Today was when it got worse. It crashed 3 more times today while I was working. I get the faded screen with the multilanguage messages. Upon restart OS X has unexpectedily shut down yadda yadda yada. Im on a MBP 2.33 C2D running 10.5 (9A581) (TOTAL CLEAN VIRGIN INSTALL yesterday afternoon) Boot ROM: MPB22.00A5.B07.

No available updates. Im gonna try a second clean install but ive heard that doesnt work either. Just letting you know that you are not the only poor sap.
 
Comment

killerrobot

macrumors 68020
Jun 7, 2007
2,220
2
127.0.0.1
No available updates. Im gonna try a second clean install but ive heard that doesnt work either. Just letting you know that you are not the only poor sap.
I've done several different installs, installing and not installing the updates available and it still happens - so I wouldn't waste your time and just hope Apple quits wasting its time and puts out 10.5.1 already.
 
Comment

wetrix

macrumors 6502
Dec 1, 2006
422
0
Auckland, New Zealand
Could it be Azureus or java itself? I'm having the same problem while leaving Azureus running. I'm going to try updating it and maybe leaving the computer without it running and see what happens.

Edit: Other threads have confirmed Azureus is the problem. A lot of users have switched to Transmission.
 
Comment

killerrobot

macrumors 68020
Jun 7, 2007
2,220
2
127.0.0.1
Could it be Azureus or java itself? I'm having the same problem while leaving Azureus running. I'm going to try updating it and maybe leaving the computer without it running and see what happens.

Edit: Other threads have confirmed Azureus is the problem. A lot of users have switched to Transmission.
Could you link to the "other threads"?
I was thinking it was Azureus too, but it didn't do it every time I had Azureus running - it was pretty random for me.
My new uneducated guess is that it has to do with Leopard's firewall and some malfunction that overloads everything if many connections are made or many packets are received or sent at once that maybe causes a read/write error.
Really I have no idea, but it sounds good to me.
 
Comment

bruinhenryd

macrumors newbie
Oct 28, 2007
6
0
It's been doing the same thing for me with azureus running. I even have my power settings to not sleep and it crashes anyway with the sleep light running.

I thought that a fresh install of Leopard would fix the problem but it doesn't so don't bother. Just run azureus when you're actively using the machine or switch to another software for now.
 
Comment

bruinhenryd

macrumors newbie
Oct 28, 2007
6
0
SOLUTION:

When running Azureus...

Go to the battery pulldown at the top right of your desktop, then select "Open Energy Saver", then under "Optimization" pulldown make sure "Best Performance" is selected. Now we are going to modify this profile by unchecking "put the hard disk(s) to sleep when possible" and make sure that the "put the computer to sleep when it is inactive" slider is set to "Never".

Now the "Optimization" pull down should read "Custom". Use this setting when you leave your computer for long periods of time with Azureus client or whatnot open and Airport running.

This should solve your Kernel panic problem. Let me know if it works!
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.