MBP will connect to router but not to Intenet

Discussion in 'Mac Basics and Help' started by cliffordmanning, Jun 9, 2009.

  1. cliffordmanning macrumors newbie

    Joined:
    Jun 9, 2009
    #1
    Hi and thanks in advance for any help and advice you throw my way.

    In essence, I own an older (the model right before unibody) 15" MBP and since I've had it in my home, it will connect to my router (recognize it, say I have 5 bars and know its name) but it will not let me connect to the internet. Occasionally it will begin to load my homepage and get hung up about 25% into it and sometimes I will get a solid enough connection to download about 3% of a podcast then it stops. I have brought it to several coffee shops and friends' houses and this problem does not exist at any of those places. Also, at my house there are other Macs, PCs, PS3s, XBox's, etc and none have the same issue (I have noticed that my iPhone's connection is also fairly spotty, weak, and elusive (I turn wi-fi on, get full bars, then when I pick up my phone, wi-fi magically disappears)). And I have performed the routine network diagnostics thing (so technical) and it does not report a problem.

    I realize that in these forums people often need more technical info, but I figured I'd post the problem and find out if there's an easy (one-size-fits-all) fix. To be clear, I'm good with technology, but when it comes to many of the nuts and bolts, I'd rather know what you specifically need to know and find someone who knows more than I do to help me find that out for you.

    Again thanks, it's been a problem for quite some time.
    Clifford
     
  2. Jethryn Freyman macrumors 68020

    Jethryn Freyman

    Joined:
    Aug 9, 2007
    Location:
    Australia
    #2
    Have you specified which DNS server to use? Sometimes DHCP doesn't detect the correct settings.

    What about firewalls?
     

Share This Page