MBP will not recognize perfectly working hard drive

Discussion in 'MacBook Pro' started by gooberguy, Sep 10, 2012.

  1. gooberguy macrumors member

    gooberguy

    Joined:
    May 17, 2010
    Location:
    Buffalo, NY
    #1
    Heres the story...

    I randomly got the dreaded question-mark on boot, signaling that the computer could not find the hardrive or the OS. Doing random reboots let it work some times, booting up to the OS.

    After a while however, after dozens and dozens of reboots, it would never boot up to the OS anymore, so I researched and my symptoms (those listed in addition to frequent crashes and delays) pointed to a failed/failing hard drive.

    So I had a warranty on my hard-drive (self-upgraded WD HD) and filed a report for a new one.

    In the mean-time I decided to test my "failed" hd with an external HD adapter and actually my other Mac read my HD just fine, and I managed to copy all my files just incase it was a fluke it worked.

    I got my new HD from WD today, and now (combined with the fact the previous HD worked just fine with an external adapter) I'm starting to think it wasn't the HD failing, but something on the MBP itself; Inserting the mac os cd, the installer can't even detect this brand new HD, either in Disk utility or in "choose your disk" part of the normal installer!

    Any ideas for DIY solutions before I bite the bullet and take it to the genius bar, likely paying loads for a repair? I would really like to avoid the repair cost as I am a very broke college student.

    Thanks in advance!
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    Try replacing the HDD cable.
     

Share This Page