MBP, Windows 10 & Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by Cuniac, Jul 28, 2015.

?

Windows 10 Upgrade

  1. Smooth - no issues

    4 vote(s)
    30.8%
  2. Ok, some issues but runs

    2 vote(s)
    15.4%
  3. Poor, runs but lots of ssues

    0 vote(s)
    0.0%
  4. Could not upgrade

    7 vote(s)
    53.8%
  1. Cuniac, Jul 28, 2015
    Last edited: Jul 28, 2015

    Cuniac macrumors 6502a

    Joined:
    Jan 23, 2013
    Location:
    Phoenix
    #1
    Ok, so Windows 10 Full is now out. I have not been brave enough to run the update on my Boot Camp partition with 8.1. I did install the dev preview with no issues though. This thread is to see how this is going. Has anyone had any issues or did it go smooth?
     
  2. T5BRICK macrumors G3

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    I have the technical preview installed, but I haven't had any problems with it. I'll upgrade to the actual release as soon as it's available.
     
  3. vbedia macrumors regular

    Joined:
    Jan 25, 2014
    #3
    Alright, I am on the same boat here. Waiting on Windows 10 to download so I can upgrade my current Windows 8.1 version. I am a little nervous though. Even knowing that my workflow is done on OS X, and Windows is just for playing games. I will upgrade as soon as the system tells me Windows 10 has been downloaded and ready to be installed.
     
  4. Lipid macrumors member

    Joined:
    Jan 28, 2014
    #4
    Everything went smooth. Except for one thing. Fn button doesn't work (but the bootcamp process is running fine), so I can't adjust volume, brightness and keyboard lights with shortkeys..
     
  5. vbedia macrumors regular

    Joined:
    Jan 25, 2014
    #5
    You may try to reinstall the bootcamp drivers for your keyboard that should be in your pendrive when you installed it.
     
  6. Cuniac thread starter macrumors 6502a

    Joined:
    Jan 23, 2013
    Location:
    Phoenix
    #6
    Reinstall the boot camp drivers and let us know if it fixes it. I'll install right now if it does
     
  7. Cuniac thread starter macrumors 6502a

    Joined:
    Jan 23, 2013
    Location:
    Phoenix
    #7
    So I just tried to update and it failed, It was able to recover my Windows 8.1. I tried it again and it did it. I needed to reinstall my boot camp drivers as my FN Keys also did not work until I did that. I cant find my AMD catalyst app anymore, but my AMD is working as GTA V still performs well. All and all seems to be working well.
     
  8. venom600 macrumors 6502a

    Joined:
    Mar 23, 2003
    Location:
    Los Angeles, CA
    #8
    Mine went 100% on two MacBook Pros and 98% on my 15". The only issue I've had is that it doesn't seem to be able to download and install the updated AMD graphics driver.
     
  9. steve23094 macrumors 68020

    steve23094

    Joined:
    Apr 23, 2013
    #9
    Late 2014 5k, upgrading from Windows 7. Download ok, install crashed out after just a few seconds with some silly error message.

    Download again (Windows doesn't remember that it's already done that). This time install onto a USB key. Crash during unpack with different error message.

    Give up. Vow not to bother trying again. Well played Microsoft.
     
  10. z31fanatic macrumors 6502a

    z31fanatic

    Joined:
    Mar 7, 2015
    Location:
    Mukilteo, WA USA
    #10
    I never got the upgrade notification so I downloaded the tool directly from MS. I start it up and it says 'Something Happened' and the only option is to close it. Can't get past it.
    W8.1 with Bootcamp on mid 2014 15".
     
  11. Lipid, Jul 30, 2015
    Last edited: Jul 30, 2015

    Lipid macrumors member

    Joined:
    Jan 28, 2014
    #11
    Yes, it worked well. Actually, there is no need to reinstall full Bootcamp Drivers package, you may go to BootCamp/Drivers/Apple folder and just run AppleKeyboardInstaller64 driver manually. Fn button now works. But there is still one more problem remains. Bluetooth is gone. Device manager says there is one device not installed - Bluetooth USB Host Controller with yellow exclamation mark. And I don't know how to setup it, Bootcamp support drivers do not help..

    UPD. Installed bluetooth drivers manually from the AppleBluetoothBroadcom64 folder in Bootcamp Pendrive. Now everything is perfect.
     
  12. Cscottrun macrumors 6502

    Joined:
    Oct 8, 2011
    #12
    Hi all. This is the first time I've used boot camp. I have Windows 10 running smoothly, except the resolution is clearly off.

    Windows says I'm running at 2560 x 1600, but this is clearly wrong, as everything is way to large and zoomed in to be anywhere near that. Anyone have any idea what went wrong/how to fix this issue?
     

Share This Page