MBP wireless problem? Bootcamp XP ok, OSX not ok

Discussion in 'MacBook Pro' started by alaibubu, Feb 19, 2007.

  1. alaibubu macrumors member

    Oct 26, 2006
    This problem only occurs at my sister's in laws' house.

    I've installed XP via bootcamp on her MBP. She can connect to the internet in XP but not in OS X. The connection bar is full in OSX but no internet connection. We've tried resetting the router but no difference.

    What's odd is that internet connection is ok at other places.

    Any ideas on what is causing this?
  2. miniConvert macrumors 68040


    Mar 4, 2006
    Kent, UK - the 'Garden of England'.
    Is OS X getting an IP address ok? If not, specify one manually that's within the range in use on the network but not being used by anyone/anything else.
  3. alaibubu thread starter macrumors member

    Oct 26, 2006
    I can't check if OS X is getting an IP address right now, but how do I get an IP address to type manually?
  4. JacobW macrumors newbie

    Dec 27, 2006
    Hmm... that sounds strange... perhaps it's something with the device (a router?) streaming to the MBP? Maybe it's the TCP/IP settings in Mac OS X? Looking at my own TCP/IP settings on my PowerBook, I see that DHCP is selected for IPv4 configuration. I don't think you can do it manually without changing the settings in the router (I am using a NetGear WGR614 v6 for my Airport). Perhaps you need to switch it to DHCP. Try if that works.
  5. alaibubu thread starter macrumors member

    Oct 26, 2006
    It seems that OSX did get an ip address. Its the same ip address used by XP. I used ipconfig in command prompt to get the ip address in xp.

    I've tried setting the ip address manually and changing the last set of numbers in the address but no luck. I've reset the router and the modem by turning them off and back on. The wireless router is a dlink.

    OSX can connect fine using ethernet though.

    Any ideas? Anybody?
  6. proverbs macrumors 6502

    Mar 15, 2005
    i have the same problem. i actually did a search and found several others with the EXACT same problem, but none had any explanations.

Share This Page