MBP with Sleep Apnea?

Discussion in 'MacBook Pro' started by warstrekkid, May 21, 2008.

  1. warstrekkid macrumors newbie

    Joined:
    Jun 29, 2007
    #1
    So I have a Macbook Pro that has a weird problem trying to go to sleep. Essentially, I'll flip the lid down, and it'll try to go to sleep. As soon as the blinker shows it's about to go to sleep, I hear whatever internal sound signaling that it's waking. If I don't flip it up, it'll wake (I assume), then realize the lid is down, try to go to sleep again, then do the same thing again. If I do flip it up, it is definitely waking up.

    I don't have bluetooth enabled, and it happens when I don't have any USB devices connected. I disabled "wake for ethernet..." and have tried it with all programs exited except quicksilver. The only thing of note is that I have it only on the adapter and do not have the battery plugged in. And it's the MBP released last summer.

    Any ideas why this is happening?
     
  2. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #2
    download and install all updates, then try a SMC reset.
     
  3. SDLSteve macrumors 6502

    Joined:
    Dec 27, 2004
    Location:
    Florida
  4. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #4
    Do you by any chance use iStat? There have been issues with MBP's and iStat not playing nice when it comes to sleep mode...I thought they got it pretty much solved but I've heard some people still have issues.
     
  5. polycat33 macrumors 6502

    Joined:
    Jul 1, 2007
    Location:
    Alexandria, VA
    #5
    I had a similar problem sometime last week... not quite the same, as the computer had been sleeping all night, and then in the morning it suddenly woke up for no reason. I opened it and closed it again, thinking maybe I had knocked the remote into my bed and rolled over onto it and clicked it, but when it woke up again after closing, I saw the remote was still there on the desk. I looked at the screen to see if there was anything going on with the comp that would make it do that, and couldn't see anything. It was really early so I just shut it off completely. Hasn't happened again...
     
  6. warstrekkid thread starter macrumors newbie

    Joined:
    Jun 29, 2007
    #6
    Definitely use iStat. I'll play around with that, see if it fixes anything. If not, I guess I'll take a stab at the SMC reset. I'll post back if either of these work; thanks!
     
  7. warstrekkid thread starter macrumors newbie

    Joined:
    Jun 29, 2007
    #7
    So I've tried a variety of stuff, and none of it has worked. Popping iStat Pro out entirely and resetting SMC didn't work. Turning off fan control, wireless, and quicksilver also didn't work. Any other ideas?
     

Share This Page