MBP won't connect...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by MDaley45, Aug 5, 2009.

  1. MDaley45 macrumors newbie

    Joined:
    Aug 3, 2009
    #1
    So I just got my MBP yesterday (15" 2.53) at the Apple store and love it the only problem is it wont connect to my home wireless network. I own a Linksys WRT54G router that I've had for about two years and has worked fine with windows machines in the past. My airport is saying that there's "No IP Address". Any advice? Thanks.
     
  2. JGruber macrumors 6502

    Joined:
    Feb 13, 2006
    #2
    What kind of Wireless Security do you have turned on?
     
  3. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #3
    Update that cheap router's firmware to the latest version too.
     
  4. MDaley45 thread starter macrumors newbie

    Joined:
    Aug 3, 2009
    #4
    I turned off the security figuring it might let it connect but a firmware update sounds like a good idea lol hopefully thatll do it
     
  5. dhena81 macrumors newbie

    Joined:
    May 6, 2009
    #5
    I was having the same problem with wireless connectivity after OSX update 10.5.6. Initially I thought my airport card was messed up because my iphone could still connect. So I went to a buddies house and I was able to connect to his router asked him what security he was running and he said WPA2.

    Come to find out my Verizon fios router comes default with WEP 128 or something so I went to the routers ip and changed it to WPA2 and that was it. I don't know if anyone else has had this problem but for some reason I can't sign on to a WEP network airport just times out or says invalid password. So if I were you I would check to see what security your running on your router like JGruber said that did it for me.
     

Share This Page