MBP wont load webpages/connect to internet

Discussion in 'MacBook Pro' started by eoli, Sep 13, 2013.

  1. eoli macrumors newbie

    Joined:
    Sep 13, 2013
    #1
    Out of nowhere, my MBP stopped loading the majority of webpages. It will still load a few (such as google), however.
    The websites always say "Unable to load the webpage because the server sent no data. Error code: ERR_EMPTY_RESPONSE"

    Airport claims it's connected, and Diagnostics says that it's working fine.
    Network setup assistant claims it cannot establish a network connection (but then i run diagnostics and it claims my connection is working; all lights are green for airport, airport settings, isp, server, etc)

    I've already tried deleting all preferred networks and re-adding mine. I tried plugging my computer into the wall with an ethernet cable but nothing changed.

    I've restarted my laptop multiple times but nothing has helped. I was temporarily able to use the internet when i switched to a guest account, but shortly after i suffered the same problems as on my normal account.

    Any help would be GREATLY appreciated.
     
  2. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #2
    When you connected via Ethernet did you turn off the wifi?

    Do you have any other devices in your house connected to wifi or ethernet, do they work fine or do they also have issues?

    Sorry for the typical support response, but have you tried rebooting your router? :)
     
  3. eoli thread starter macrumors newbie

    Joined:
    Sep 13, 2013
    #3
    I'm currently on the same network using a different laptop, so i know it isn't the network itself.

    And yes, i did already try restarting the router. :/
     

Share This Page