MBP wont play video from apple.com

Discussion in 'MacBook Pro' started by PeteyV, Mar 2, 2011.

  1. PeteyV macrumors member

    Joined:
    Feb 10, 2011
    #1
    For whatever reason my MBP wont play video from apple.com. I was trying to view tutorials and the divx player tries to play them but an error comes up saying that the video couldnt be downloaded and wont be played. Any help?
     
  2. Apple Corps macrumors 68030

    Joined:
    Apr 26, 2003
    Location:
    California
    #2
    Why are you using a divx / or other player???
     
  3. PeteyV thread starter macrumors member

    Joined:
    Feb 10, 2011
    #3
    I downloaded it to view a video that I had on a USB and I guess it somehow defaulted itself. I guess now my question is what is the default player (QuickTime?) for web video and how do I default that for web videos?
     
  4. whitedragon101 macrumors 6502a

    Joined:
    Sep 11, 2008
    #4
    I have the same issue. I installed DivX player because some site asked me to, now loads of quicktime web videos crash sighting DivX as the culprit in the error report.
     
  5. PeteyV thread starter macrumors member

    Joined:
    Feb 10, 2011
    #5
    Same thing is now happening now with my iMac.
     
  6. AdamRock macrumors 6502a

    AdamRock

    Joined:
    Aug 30, 2010
    Location:
    Toronto
    #6
    There should be an uninstaller in the /Applications/Divx folder.

    If you can't find the uninstaller, just delete the Divx stuff from the
    /Library/Quicktime and /Applications folders. The preference files are
    in ~/Library/Preferences/, filenames beginning with com.divx.
     
  7. whitedragon101 macrumors 6502a

    Joined:
    Sep 11, 2008
    #7
    Found the solution.

    When in safari click

    Safari -> Preferences
    select extensions

    Here you can either turn DivX extension off or uninstall it completely.
    (I just turned it off so I didn't have to wait for uninstall).
     
  8. Broward macrumors newbie

    Joined:
    Feb 27, 2011
    #8
    I experienced a similar problem with Apple's site today, not involving divx however. The videos would load, audio would play, but no video would appear. Removing click2flash fixed the video on Apple's site, as unlikely a solution as that sounds.
     
  9. PeteyV thread starter macrumors member

    Joined:
    Feb 10, 2011
    #9
    Thanks. That seemed to have worked. I'm still getting familiar with this OS.
     

Share This Page