MBP won't power down normally

Discussion in 'MacBook Pro' started by flavorOfLocke, Jan 29, 2012.

  1. flavorOfLocke macrumors newbie

    Joined:
    Jan 29, 2012
    #1
    OK, I've been Googling and searching various Mac forums for a few days intermittently now, but can't find a close enough case that matches mine so here we go:

    My mid-2009 MBP, in the last week, has stopped responding to the power button while the computer is powered on. If I try to shut down or restart via the :apple: menu, nothing happens.

    Nothing suspicious is showing up on the Activity Monitor under All Processes and no applications are opening.

    I was changing some things in the System Preferences pane, but I haven't a clue what I could have possibly altered that would cause this.

    The only ways I can shut down right now is by doing a force shut down by holding the power key down (so I'm guessing that switch isn't broken) or by opening up Terminal and entering: sudo shutdown -h now.

    It's worth noting that I've run MacKeeper, OnyX, repaired the disk/permissions via the RecoveryHD, and I just did a clean install of the OS within the last month.

    Thank you. I can see that this forum is very helpful and I will greatly appreciate any help!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Perhaps it would help if you posted screen shots of Activity Monitor after you've closed all apps.
    So I take it you mean you can't shut down by clicking  > Shut Down.
    I don't recommend using MacKeeper at all, and I highly recommend you uninstall it. You don't need "cleaner" or "maintenance" apps to keep your Mac running well, and some of these apps can do more harm than good. Some remove files/folders or unused languages or architectures, which does nothing more than free up some drive space, with the risk of deleting something important in the process.

    These apps will not make your Mac run faster or more efficiently, since having stuff stored on a drive does not impact performance, unless you're running out of drive space. Some of these apps delete caches, which can hurt performance, rather than help it, since more system resources are used and performance suffers while each cache is being rebuilt.

    Many of these tasks should only be done selectively to troubleshoot specific problems, not en masse as routine maintenance.

    Mac OS X does a good job of taking care of itself, without the need for 3rd party software. Among other things, it has its own maintenance scripts that run silently in the background on a daily, weekly and monthly basis, without user intervention.

     
  3. flavorOfLocke thread starter macrumors newbie

    Joined:
    Jan 29, 2012
    #3
  4. GGJstudios, Jan 30, 2012
    Last edited: Jan 30, 2012

    GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
    No, Onyx is fine. You may find traces of MacKeeper left behind. The most effective method for complete app removal is manual deletion:
    Be sure to search for "MacKeeper" and "zeobit" and "AntiVirus" to find related files/folders. If you find any and delete them, restart your computer before proceeding with the instructions below.

    As for your Activity Monitor screen shot, while it doesn't show all processes, start eliminating processes that show "michael" as the User. One at a time, quit a process, then try shutting down, using  > Shut Down. Keep doing that until you successfully shut down. That should help you identify the culprit. Quit them in this order:

    MemoryFreer
    prl_disp_service
    Cinch
    Grab
    any others that are clearly associated with a 3rd party app you installed.
     
  5. flavorOfLocke thread starter macrumors newbie

    Joined:
    Jan 29, 2012
    #6
    I've deleted all the MacKeeper files I could find per your instructions and my computer is already faster. Thank you for helping me with that!

    Here is a list of what processes I have it narrowed down to, as quitting each of the obvious 3rd party applications and then choosing :apple: > Shut Down hasn't worked yet. (Grab is only running because I'm using it to take a screenshot. I still tried quitting it after the screenshot and trying :apple: > Shut Down—no dice.)
     

    Attached Files:

  6. flavorOfLocke thread starter macrumors newbie

    Joined:
    Jan 29, 2012
    #7
    It seems the issue was MacKeeper.

    I uninstalled MacKeeper a day or two ago and last night did a fresh install off of a Lion USB, followed by a Migration Assistant file transfer that only excluded the "Other files and folders" under both my user account and at the very bottom of the list.

    Thanks, GGJstudios, for ultimately helping me solve this issue!

    DEATH TO MACKEEPER.
     

Share This Page