MBP wont run on battery & shuts off randomly with charger

Discussion in 'MacBook Pro' started by allan1, Jun 16, 2011.

  1. allan1 macrumors newbie

    Joined:
    Jun 16, 2011
    #1
    Someone brought me a mid 2007 2.2 ghz MBP that wont run off what seems to be a fully charged battery and will only run for 10 minutes or less off the charger. I reset the PRAM and SMC, repaired permissions, did a safe boot, and nothing seems to help. pic of battery info attached, it doesn't have an X over the battery, it just says "not charging."
    Any ideas on whats wrong with it?

    [​IMG]
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    PRAM/NVRAM has nothing to do with battery/power/charging issues. Resetting it will not help. Neither will repairing permissions. Only resetting the SMC addresses such issues. It appears your battery is not recognized or is completely drained. Make sure it's properly seated and let it charge for a while. If that doesn't work, you may need a new battery.
     
  3. allan1 thread starter macrumors newbie

    Joined:
    Jun 16, 2011
    #3
    Thanks, i'll let it charge for a few hours, but I don't think it will do anything. When detached from the MBP, the battery light shows a full charge, when placed on the MBP, it shows no charge. So a new battery should fix all issues?
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Sounds like it.
     

Share This Page