MBP won't sleep automatically when on AC power

Discussion in 'MacBook Pro' started by justflie, Sep 9, 2007.

  1. justflie macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #1
    Hey all,

    Annoying problem that's costing me my battery: When my MBP is plugged into the AC Adapter, it refuses to sleep automatically according to the settings in Energy Saver. I can sleep it manually just fine (ie Apple-->Sleep). However, I usually have it on the "Normal" setting which sets the sleep when idle time to 10 minutes. It doesn't do that, it just keeps right on running. So then I tried doing a custom setting, reducing it to 1 minute. I also restarted (and didn't open any programs) and unplugged all peripherals just to be sure. It didn't make a difference. Also, I repaired permissions, verified my disk, reset the PRAM and SMC. That covers anything I can think of. Any ideas? It's an MBP 2.4 ghz. Running 10.4.10, fully updated. And it sleeps automatically just fine when I am running on battery.
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Did you try disconnecting from your network before too?
     
  3. kolax macrumors G3

    kolax

    Joined:
    Mar 20, 2007
  4. justflie thread starter macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #4
    I did. I'm usually on a wired network so the time that I tried without anything (including the ethernet cable) plugged in should have sufficed.

    Yes and no. From time to time, I use a bluetooth mighty mouse (for games or projects where I'm doing a lot of work with the mouse). However, when I was trying to solve this problem, the mouse was turned off and was not in use.
     
  5. The Stig macrumors 6502a

    The Stig

    Joined:
    Nov 4, 2006
    Location:
    On the track
  6. justflie thread starter macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #6
    I also tried making a new account and the problems persisted there.
    Also, it is doing the same thing now whether on battery or AC power.
     
  7. wildthing1994 macrumors member

    wildthing1994

    Joined:
    Apr 8, 2007
    #7
    I think this may solve your problem. First open the energy saver,second go to settings for ac power adaptor, third chose an optimation, fourth uncheck the wake option for the wake option. Than try and see if that worked for you.
     
  8. justflie thread starter macrumors 6502a

    justflie

    Joined:
    Nov 29, 2005
    Location:
    Red Sox Nation
    #8
    Nope, that didn't do it. Thanks for the idea though. Any others?
     
  9. Habakuk macrumors 6502a

    Joined:
    Jul 10, 2007
    Location:
    Vienna Austria Europe
    #9
    I had similar issues and it WAS indeed the bluetooth mightymouse. The solution was to turn off the third option. Uncheck "allow bluethooth devices to wake up the computer" *) in the bluetooth preferences. I did not help to turn off the mouse itself.

    *) Sorry I don't know the exact words because I am using a German-language OS X.
     
  10. JeffL22 macrumors newbie

    Joined:
    Mar 28, 2011
    #10
    I had the same problem...

    However, I talked with Applecare on the phone for HOURS about it. They tried every single reset/setting/test imaginable. Finally, they recommended I reinstall Snow Leopard, which I blamed for the issue as it slept fine before the "upgrade". Well...I'm not going to do that. So, I suggest you call Apple and give them hell about it. They claimed to have never heard of the problem before....just like when my same Mac didn't wake from sleep two years earlier...they never heard of that either even though thousands of others were complaining about it online...then magically, an update fixed it one day. So, keep hammering on Apple...they know about it.
     

Share This Page