MBP wouldn't boot properly =/

Discussion in 'MacBook Pro' started by KidZgOtMac, Aug 10, 2011.

  1. KidZgOtMac macrumors regular

    KidZgOtMac

    Joined:
    Jul 20, 2010
    Location:
    Mayaguez, Puerto Rico
    #1
    This morning when I turned it on after leaving it charging for like 5 hours it played the startup sound and went to the apple logo white screen and it stood there forever, I could move the mouse though. So I turned it off and it sounded like when it turns on that you can hear something move inside. Turned it on for at least three more times and it kept doing the same thing. I let it be for a while then turned it off, when I turned it on it made a harsh sound then it finally booted properly. I recently did a Windows 7 partition, does that have anything to do? I got scared for a moment there.
     
  2. snaky69 macrumors 603

    Joined:
    Mar 14, 2008
    #2
    Make a backup of your stuff right now, sounds like a drive going bad.
     
  3. KidZgOtMac thread starter macrumors regular

    KidZgOtMac

    Joined:
    Jul 20, 2010
    Location:
    Mayaguez, Puerto Rico
    #3
    I thought about that. I was also playing some loud music with killer bass on some studio speakers yesterday. Maybe the vibrations messed the HDD up or something.
     
  4. mhockey91 macrumors newbie

    Joined:
    Aug 10, 2011
    #4
    i doubt that loud music would mess up your hdd they make macs with the best quality but i think making a backup of your drive is a good idea
     

Share This Page