MBP1,Boot failure?

Discussion in 'MacBook Pro' started by CharmPeddler, Jan 25, 2012.

  1. CharmPeddler macrumors newbie

    Joined:
    Jan 25, 2012
    #1
    Hi guys, I've looked around for a good looking community to get some help with my wife's MBP (1.1, 2.16ghz, 2gb RAM, 100gb HDD) and this looks like the perfect place. Here is what's going on:

    The batter is kaput (not the subject of this post) and will only last for about 2 mins, I mistakenly turned off the "lite switch" to the outlet my wife had her Laptop plugged into. Well when we returned home she turned it back on only to see this: http://img.photobucket.com/albums/v628/Charmpeddler/Fore%20Sale/MBPBootError.jpg

    I have tried a few things a friend suggested (conversation posted below) but i have come up with nothing at all.

    Our BIGGEST issue is that my wife writes for a living (novels) and she has not been diligent with her Time Machine backups. She also tells me that the last days worth of changes was not "saved" in word... SO if it was not for the lack of saving her progress i would ( after conformation from here that it is "just the HDD") buy a new HDD, install the OSX 10.6 and use the current drive as an external to pull needed files.

    Trial and error diagnostics already tried:
    "
    so far...
    Booting with "Cmd+V" or "Shft+Cmd+V" shows Black screen with same white txt. (there is a little more txt before, but nothing after. unable to type even though the courser shows (solid, not blinking).
    Booting with "Shft" shows no difference.

    I booted from the install disk and ran the Disk Utility (Verify disk showed clean) (ran the verify then Repair twice) still unable to boot. I was hopping i might be able to run one last Time Machine backup from the live CD but i'm not finding that option, just the restore option.

    I am unable to get fsck to run from within terminal. i've tried SUDO, and other options, i tried to get a "fsck help" or "fsck ?" thinking i was not getting the syntax correct, but nothing happens.

    IF i can't get this working again, i'm REALLY hopping it's "just" the HDD and i could buy a 120gb+ drive for cheap and just switch out hdd's and be good to go. is there anything in the little info i've given that says we could be so lucky as to only have to replace the HDD?
    "

    Thanks for any and all help.
     
  2. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #2
    Is this not the correct place for this type of help?
     
  3. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #3
    not even a "get the heck out of here you PC mongrel"?
     
  4. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #4
    I am not sure where to go with this. Man fsck works to give you the manual and the options available. Good luck.
     
  5. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #5
    can you tell me if i was typing the fsck correctly? I'm not sure if the fsck was not working or if i was doing it wrong.

    Thanks.
     
  6. squeakr, Jan 27, 2012
    Last edited: Jan 27, 2012

    squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #6
    you might try the fsck_hfs command and if running it from the disk utility launch try it with the -g flag. I am not overly familiar with the fsck command but was able to preen this from the "man fsck" and "man fsck_hfs" commands from the terminal.

    It looks like your boot partition can't be found, which could mean your data may or ay not be there and accessible. At least you have a TM back up to regain some of the stuff.
     
  7. jwksmith macrumors member

    Joined:
    Apr 27, 2008
    Location:
    Calgary
    #7
    If you have a USB drive, either disk or flash, you can install OSX on it from your CD. You can then boot to that drive and get access to the disk on your computer. That should let you copy any files off it if it is accessible.

    I think, even with a full install, you will only need 20 GB or so. It's a bit slow but it will work.

    Alternatively, if you have another mac, you can access the sick disk using firewire.
     
  8. pscraig macrumors member

    Joined:
    Apr 9, 2008
    #8
    This is exactly what I would do. If you are saying that your wife did not save her work in Word for several days, then that data could be lost. However, Word has autosave features that *may* have saved the data.

    Reinstalling Mac OS might also help, but might also overwrite any temporary files used by Word to hold unsaved data.

    MS has an article that sort of addresses how you might have to handle recovery of the data: http://support.microsoft.com/kb/892956

    What you experienced is a kernel panic, something loading at boot is corrupted. Install OS X on a new drive, use Migration Assistant to pull the data over via USB/FW cable, then once you're done use the old drive as a backup drive if you don't already have one.

    If her laptop is that mission-critical consider using the spare external drive as a clone backup-get Carbon Copy Cloner and copy the entire drive. Now you have a hot spare with absolutely everything contained on the master drive.
     
  9. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #9
    Thanks for the reply guys much appreciated.

    jwksmith: i'll me trying the firewire with her moms MBP, That sounds like the perfect idea.

    pscraig: thanks for the MSOffice article link, that is exactly what i was looking for.

    I hope to combine the firewire with the Word recovery. Then i'll buy a new HDD cause i'm pretty sure we have had somekind of issue with the HDD before, Might was well get a new one.

    THank you everyone!
     
  10. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #10
    Looks like i might have another issue...
    I downloaded Linux Mint and while booting the live distro decided to run the Memtest86. This is only the second time i've ever ran this test so i wasn't sure if these results were completely world crashing or if they needed to be taken with a grain of salt...

    http://img.photobucket.com/albums/v628/Charmpeddler/Fore Sale/2012-01-28_22-24-29_875.jpg

    I'll be testing each ram stick individually later today to see if it could be only one of the sticks causing the issue.
     
  11. CharmPeddler thread starter macrumors newbie

    Joined:
    Jan 25, 2012
    #11
    I successfully used Linux mint to pull of important files. Wiped the HDD, re-installed OSX and then performed a Time Machine restore. Her MBP now seems to be working correctly.

    I will be keeping an eye out for a good deal on a HDD because i feel it would be a good idea to replace it before something like this happens again.

    Thanks to everyone for the input and help.
     

Share This Page