MBP2010 - Anyway to disable the nVidia GPU

Discussion in 'MacBook Pro' started by wilflare, May 27, 2014.

  1. wilflare macrumors member

    Joined:
    Sep 3, 2010
    #1
    My MBP2010 has served me well... and I sure hope it holds out for another 6 months (till the end of this year) when I finally complete my undergraduate course.

    Any suggestions on how I can disable the nVidia GPU? I don't really need the dedicated GPU anymore... and it kicks in whenever I run things like Wunderlist, flux and Chrome.

    I know Safari works better (and does not kick in the dedicated GPU) but I use Chrome on my mobile and desktop PC so the syncing feature is much needed.

    Any suggestions?
     
  2. Freyqq macrumors 601

    Joined:
    Dec 13, 2004
    #2
    not possible on the 2010 =\

    you can avoid programs that use the dgpu like safari/firefox
     
  3. wilflare thread starter macrumors member

    Joined:
    Sep 3, 2010
    #3
    that's a bummer. would really like to use Chrome but it always toggles the dGPU
     
  4. Freyqq macrumors 601

    Joined:
    Dec 13, 2004
    #4
    there is a workaround, but it is annoying to use. There is a way to use an automator script to force igpu, as it was something they were testing and put the switch into the program.

    https://code.google.com/p/chromium/issues/detail?id=111720

    "FYI: with r158128, users can overwrite Chrome's behavior by using commandline switch

    --gpu-switching=force_integrated or
    --gpu-switching=force_discrete

    Note that if you have other programs that switch to discrete GPU, then Chrome won't stop that from happening even if force_integrated is passed.

    Happy saving battery."
     
  5. wilflare thread starter macrumors member

    Joined:
    Sep 3, 2010
    #5
    thanks. i kinda resigned to using Safari on my MBP 2010 since it's better for battery for now right?

    maybe when I get a MBA Retina (whenever that's out)
     
  6. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #6
    How about using gfxcardstatus?
     
  7. UBS28 macrumors 6502a

    Joined:
    Oct 2, 2012
    #7
    Yes it is. Use that program that enable to switch GPU's.
     
  8. raptor402 macrumors 6502

    Joined:
    Jun 30, 2011
    #8
    I have a mid-2010 15" MBP and have been using gfxCardStatus for almost two years without a hitch. It's the best solution to avoid the kernel panics that the GT330M brings, especially since even Chrome fires up the dGPU on this MBP.

    Raptor
     
  9. wilflare thread starter macrumors member

    Joined:
    Sep 3, 2010
    #9
    I have tried this but it doesn't seem to work for me. dGPU gets fired up even if I switch it to integrated only on gfxCardStatus
     
  10. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #10
    You need to activate the iGPU twice.

    Reboot your machine and make sure no programs are running. Go into the Gfxcardstatus menu bar and select the iGPU. Your system will pause for a brief moment. After it does that, go back to the menu bar, and you'll see that it still says "Dynamic Switching." Select integrated only again, and it should be locked.

    I had the same issue with my 2011 MBP, and simply selecting the iGPU a second time seemed to fix it.
     
  11. raptor402 macrumors 6502

    Joined:
    Jun 30, 2011
    #11
    There are a few issues with gfxCardStatus but they're pretty easy to circumvent. I've never experienced the issue saturnotaku has written about above but you should give his/her suggestion a shot first.

    If there are any dependant apps (apps that use the dGPU) running, close them. In many cases, closing the last app will automatically switch you to dGPU (the primary and most irritating issue). After that, select iGPU only and you should be good to go.

    Raptor
     
  12. chrfr macrumors 604

    Joined:
    Jul 11, 2009
    #12
    Also remember that the external display port requires the dGPU.
     

Share This Page