MBPr 13" will not connect to internet, every other device on the network will.

Discussion in 'MacBook Pro' started by wits-end, Nov 23, 2013.

  1. wits-end, Nov 23, 2013
    Last edited: Nov 23, 2013

    wits-end macrumors newbie

    Joined:
    Nov 23, 2013
    #1
    Hi All,

    First time posting as I've exhausted all my theories and other thread advice.

    My recently purchased Haswell Pro Retina has been an absolute dream for the last couple of weeks - until last night. Staying at my girlfriends for the weekend and it won't connect to be Internet. It connects to the network every time no bother, DHCP allocates an IP and I can use the Remote app from my iPhone.

    It worked when I first connected, and occasionally it works after resetting the router, but never for long. As soon as the screen sleeps I once again have no connection. It now won't connect at all - but is still on the WAN fine.
    My girlfriends windows PC/Linux laptop and my phone all connect great, it's all go for them.

    So far I've tried; resetting the router, restarting the mac, switching wifi on and off. (Waiting various lengths of time in between all of these attempts), changing to manual IP, running network diagnostics (truly useless, for the record), restarting safari (although is the entire mac without Internet), deleting saved networks and cache and re-adding as 'other network'.
    Unfortunately I do not have access to the router settings as no one here knows the password and the default is changed.
    I have also tried the laptop in coffee shop and it works fine, as it has at my house and round campus.

    Really beginning to miss that Ethernet port...

    Any help would be greatly appreciated, thanks.
     
  2. priitv8 macrumors 68020

    Joined:
    Jan 13, 2011
    Location:
    Estonia

Share This Page