MBPR - Eclipse - Android Virtual Device

Discussion in 'MacBook Pro' started by Diveflo, Jun 22, 2012.

  1. Diveflo macrumors regular

    Joined:
    Mar 12, 2008
    #1
    Hey guys,

    I got my new MacBook Pro w/ retina yesterday and I love it...but of course some apps are not optimized for retina yet.
    One of those is the Eclipse IDE...it got pixelated text&graphics, but there is a workaround for that.

    //if anyone is interested:
    https://bugs.eclipse.org/bugs/show_bug.cgi?id=382972

    But I found something else that is not working and I was wondering if anyone found a solution for this.
    Whenever I try to run my Android apps within the emulator the window is WAY to big (so 1/4 is the actual app and the rest is whitespace), which wouldn't be that bad, but the mouse clicks get mapped to the whole window...

    Does anyone else experience this and found a solution?
     

    Attached Files:

  2. Rudy69 macrumors 6502a

    Rudy69

    Joined:
    Mar 30, 2009
    #2
    It actually "works" but it's not very usable right now. It renders at 1x instead of 2x (thus taking only 1/4 of the window). Clicks are registered properly according to the WINDOW and not the rendered interface. So clicking in the middle of the window will be the same as clicking in the middle of the application (even though it looks like you're click the very bottom right of the application)

    edit: oh and the solution is to wait for now I think :/
     
  3. gazzik macrumors newbie

    Joined:
    Jul 11, 2012
    #3
    I am experiencing the same issue..tried to change the resolution of the virtual device but still no good. Anyone have a solution for this yet?
     
  4. Mongol macrumors member

    Joined:
    Jun 12, 2012
    #4
    this is a known issue

    the workaround is getting something like setresx and set the resolution to be a non-retina scaled resolution.
     

Share This Page