MBPr is receiving regular SMS but doesn't ri

Discussion in 'iOS 8' started by iPersian, Oct 20, 2014.

  1. iPersian macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
    #1
    MBPr receiving is regular SMS and that seems ok but the mac doesn't ring when someone calls, only the iphone does.

    any one who has calling working.
     
  2. Stuke00 macrumors 68000

    Joined:
    Oct 11, 2011
    Location:
    Collinsville,IL
    #2
    Calls work for me. This was working in 8.0
     
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    Works for me. Actually, as I have four devices in the room, there is a ridiculous amount of noise when I get a call or an SMS :)

    A.
     
  4. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
    #4
    ok i can't getting it work. do you also use apples iCloud account mail? i only use gmail set up to my iCloud account.

    ----------

    ok i can't getting it work. do you also use apples iCloud account mail? i only use gmail set up to my iCloud account.
     
  5. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
    #5
    I've got two macs with identical setup, one imac 2008 model and one MBPr model. the calls work on the imac but not on the newer MBP
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    One thing that seemed to make a difference for me was making sure that my Messages settings under Account were consistent. You can have different items checked there to indicate what Apple IDs and/or phone numbers are used. As I have several, I was not always consistent as to which ones I had chosen. Making them all consistent let me get SMS and phone calls working consistently.

    A.
     
  7. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
  8. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #8
    Well, consistency being what it is, 'yes'. In my particular case, adding the phone number to my Macbook account allowed me to receive the authentication message when before it got nothing. I am speculating that being consistent may help in other areas - but in that case I am making stuff up.

    A.
     
  9. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
    #9
    tripled checked everything. im convinced its a bug now.
     
  10. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
  11. HotIce macrumors regular

    Joined:
    Oct 7, 2014
    #11

    -Turn off WiFi calling if it is enabled.
    -Make sure iPhone Cellular Calls is switched on(Check both devices)

    iPhone: Settings---->Facetime---->iPhone Cellular Calls
    Mac: Facetime---->Preferences---->Iphone Cellular Calls

    -Make sure the Caller ID is set as your phone number

    -Log out of iCloud on your Mac and your iPhone.
    -Log back into iCloud on your devices.
    -Restart devices
    -Make sure you're connected to the same Wi-Fi Network.
     
  12. ttmrn macrumors regular

    Joined:
    Oct 6, 2014
    Location:
    tx
    #12
    No problem with mine. Working since iOS 8 too.
     
  13. iPersian thread starter macrumors regular

    Joined:
    Oct 23, 2012
    Location:
    Copenhagen, Denmark
    #13
    all set up, does not help...

    ----------

    im getting crazy. even apple support didn't know what to do.

    im sensing that there is either a bug or there is some setting outside facetime/icloud setting on the MBPr that stops it from functioning.cant see what that could be.
    __________________

    ----------

    I've done all of that 2-3 times now. its all the same, imac works but the machine i use most the MBPr does not.
     
  14. bigred7078 macrumors 6502a

    bigred7078

    Joined:
    May 6, 2010
    Location:
    North Carolina
    #14
    This is what worked for me....


    On your iPhone, go to Settings > Messages > Text Message Forwarding, and turn on your Macbook
     

Share This Page