MBPr issues running SolidWorks (lagging)

Discussion in 'MacBook Pro' started by tranceplex, Jun 26, 2012.

  1. tranceplex macrumors newbie

    Joined:
    Jun 26, 2012
    #1
    Hello MacRumors Community, I'm posting on here to see if any of you are having issues running SolidWorks on your new Retina. I'm running SolidWorks 2011 SP4 and it runs very slow in general both in Bootcamp and in Parallels. The lag is most apparent when zooming, panning, and editing 2D drawings. There is also a lag editing sketches that build up a extrude in 3D.

    I'm running the same settings as before on my old MacBook Pro so it isn't the performance and rendering options and I've tried all the tricks, turning on 3GB switch, turning down Windows 7 graphics, turning down SolidWorks rendering performance, etc. I'm also positive it's running through my GFX card and not through software OpenGL. My guess is a compatibility issues between SW and the new 650m card but I'm just wondering if any of you have had this problem.
     
  2. tranceplex thread starter macrumors newbie

    Joined:
    Jun 26, 2012
    #2
    Update: I figure out that there is a bug in Solidworks 2011 SP4 that has compatibility issues with the Retina hardware. After updating to SP5, everything is now working great and the GFX hardware is more than sufficient. Hope that helps anyone else that had the same issue as me.
     
  3. ronnyguru macrumors newbie

    Joined:
    Jul 14, 2012
    #3
    Parallel to BootCamp

    Thanks for early testing w/ MBP Retina + SW !
    MBPr would've been a deal breaker if SW didn't work well on it.

    Question -
    I'm on a MacBook Pro Retina
    - want SolidWorks but considering Parallel vs BootCamp

    I'd prefer Parallel since SW is the only thing i need Windows for. really don't want to have to reboot into Win7 every time i want to run SW.

    Any big limitations of doing SW on Parallel ? My models are not very complex - at most 40 parts Max in an assembly. I will be doing a bit of rendering but I can run those on a remote PC I have.

    Some must have features - Center scroll button to rotate with 3btn mouse must work.

    Thanks in advance.
     
  4. ronnyguru macrumors newbie

    Joined:
    Jul 14, 2012
    #4
    Updating registry settings to make sure it's not using OpenGL and your hardware GPU

    So to make sure your MacBook Pro is NOT going into Using OpenGL mode -

    use this workaround.

    Open regedit, (windows button > run > regedit)
    * you should never mess with regedit unless you know what you're doing , but this regedit should be harmless , either way back up your registry if you're not sure .

    See the image below and go into the shown area - (see the tree location on the bottom of the jpeg.

    And change the values for the two items (shown with pink arrows)

    - Ronny
     

    Attached Files:

  5. Namssorg macrumors newbie

    Joined:
    Oct 9, 2012
    #5
    Hi- I am having the same issue. I am on a Macbook Pro Retina running Parallels 7, and Solidworks 2011.

    I've made the registry edits (and have read similar fixes on other forums) but no matter what I change the value to, the 'Software OpenGL' checkbox in Solidworks stays checked and grayed out. I have Parallels set up to use 3d acceleration, so I'm out of ideas.

    Any thoughts?
     
  6. ronnyguru macrumors newbie

    Joined:
    Jul 14, 2012
    #6
    It is checked and greyed out ? or It is just greyed out ?

    With SW 2013 it looks like you can only change that setting while you have NO models open. So open SW, and goto options - performance and see if it's unchecked.
    Also , on the Mac side - there is a auto switching of video card that needs to happen - by default it should turning on , but if you want to manually turn it on - you can install a program called : http://gfx.io

    Also if you want to use the trackpad to do rotation (three fingers down) - there's way to do that using MagicPrefs (it's free) - it's really a big help if you won't wanna use a mouse all the time.
    in the magic prefs just turn on three finger = middle click.
    But you will need to change your settings for your trackpad in the mac settings :
    turn on 3 finger drag, and 2ndary click set to 2 fingers,
    - and under more gestures , i have them all checked, but check to make sure you don't have 3 finger gestures , other than the 3 finger + thumb gesture (which is really a 4 finger gesture)

    Once that is all set, and you've magicPerf to do 3 finger = middle click , you should be able to rotate object by just using 3 finger ( no need to press ) just drag around
    works really well !
     

Share This Page