MBPr Retina 15in Wifi or Thunderbolt Internet not working

Discussion in 'MacBook Pro' started by FatGuy007, Nov 15, 2012.

  1. FatGuy007 macrumors 6502

    Joined:
    Apr 8, 2012
    Location:
    New York
    #1
    And what's wierd is if I connect to the thunderbolt display ethernet, it works perfectly. I restarted twice, didn't try PRAM or SMC restart yet but those have nothing to do with the issue.
    Seriously this laptop is starting to piss me off, first very slight creaking on trackpad, then my right speaker doesnt work or really low (and whats wierd that if I use my Earpods, the right earbud doesnt work, but when i plug it into my phone it works perfect, very strange).
    I've had this laptop (thankfully with samsung display) for nearly 3 months sure it's an absolute piece of architecture and amazing, but the issues are very annoying. A 2500$ laptop should not come with these (my old 1300$ macbook pro came with no issues).
     
  2. harrouet macrumors newbie

    Joined:
    Nov 28, 2012
    #2
    Me too !

    Very strange error, but my rMBP15 is now in the same state as yours: no HW for WiFi, and no Thunderbolt ports either. Bluetooth is still here.

    Actually the laptop died on me while doing emails. I though it had overheated. I tried to turn it back on but the screen remained black. No light on the Apple logo. Then did P+R+alt+cmd+pwr to reset the PRAM. After 3 tries, it came back, but no WiFi hw or Thunderbolt. It looks like a chipset failure to me.

    Apple is sending a brand new one, but my machine was 1 week old only. It hurts to think that I shed 2600€ for a lemon !

    I asked Apple to be offered AppleCare protection for free, since I don't feel reassured with their hardware. They refused and I know other people who were going to buy the same machine who are going to think twice.
     
  3. Xenn0X macrumors regular

    Joined:
    Jan 25, 2008
    #3
    why do people allways want freebee's when a product fails?
    penny wise pound foolish if you bough a 3K mac without 300$ applecare..

    to the point: strange u guys have same issue..
     

Share This Page