MBPr Wifi Connected But No Internet, Intermittent Problem

Discussion in 'MacBook Pro' started by Yakusoya, Oct 26, 2012.

  1. Yakusoya macrumors newbie

    Joined:
    Feb 7, 2012
    #1
    Hi all, ever since I got the MBPr for work several months ago, I've been having intermittent problems with my internet. Sometimes when I start up my computer, it would show I'm connected to wifi but I cannot access the internet. I have also connected the Ethernet to Thunderbolt adapter. When this problem occurs, the ethernet adapter and wifi are both shown as connected in Network settings. If I turn wifi off and back on, the icon would no longer show as connected and has a ! symbol on it and it would show disconnected in Network settings. Usually, a restart fixes this but sometimes takes several tries.

    This problem occurs whether on my work network or home network. My coworkers with MBPr and connecting to the same network have no problems.

    I've been to Apple Store 5 times already and they have NOT fixed it nor do they know what's going on. They've ran their Genius Bar hardware test every single time with no problems and it connects to their store wifi too. Here is what I've tried.

    NOTE: When I first installed MBPr, I did a restore from Time Machine. I thought this was the problem but I did a clean reinstall of Lion OS without any Time Machine recovery and still same problem...

    1. All system updates available installed.
    2. Disabled Bluetooth when problem occurs, no difference.
    3. Factory reset network settings.
    4. Wiped everything and reinstalled Lion 10.7.5, no recovery/migrate from Time Machine except for applications.
    5. Apple replaced logic board.
    6. Factory reset network settings again.

    I'm still getting the problem occasionally. But now, it's starting to kick me off while I'm on the network. Before, it would only occur when I start up the computer (I don't put my computer to sleep). I've grown so tired of going to Apple Store back and forth. Has anyone else experienced this problem? :( Any help or tip is GREATLY appreciated!
     
  2. Mrbobb, Oct 26, 2012
    Last edited: Oct 26, 2012

    Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #2
    One usually shouldn't have WIFI and ethernet connected at the same time on the same subnet. Ur reason for doing so being...?

    What happens when u disable WIFI and use ethernet connection only?
     
  3. Yakusoya thread starter macrumors newbie

    Joined:
    Feb 7, 2012
    #3
    Normally, it works if I use one or the other. But it's just that the ethernet adapter tends to be faulty. When I plug it in, sometimes it stays disconnected for a long time, sometimes it turns to green "Connected" in a few seconds.

    But when the problem occurs, I tried to switch between both, with just one connected, it stays disconnected after I unplug and plug it back in. I also tried to only use wifi now, but still the internet problem happens occasionally. Starting yesterday, it kicked me off the wifi network in the middle of the day which hasn't happened before. I suddenly get no internet even though wifi icon shows connected until I unplug it.
     

Share This Page