MBpro Battery again

Discussion in 'MacBook Pro' started by Mattia Sullini, Jan 11, 2008.

  1. Mattia Sullini macrumors newbie

    Joined:
    Oct 27, 2007
    #1
    Working with MBPro intelcore 2,16, first generation, then. 10.5.1, battery firmware updated. Well, i already posted about the problem i got with both my batteries losing charge...and after apple having replaced one i could check what's going on with them. The problem seems to be that, even if the battery icon tells me that the battery is fully charged, by checking both on iStat, Coconut and System Profiler, what i get is that 80Ah are missed to have the full charge. When i then unplug the power, use the computer and then plug it again, the system considers the incomplete charge to be the battery full charge capacity, and then all the monitoring apps tell me that my battery health has dropped to 2% less. And this happen everytime i complete such a cicle (charge, unplug, use, replug). But as one could expect , that 2% is not missed: in facts if i let the computer drain all the battery it stops (as expected) but then awakes from sleep with a charge of -1Ah (!!!), keeps on working for a few minutes, and then goes to sleep again. And this keeps on cycling until the battery recovers its real health, that in my case is something around 85%. Does any of you experience the same?

    Sorry for my awful english, i hope you caught the overall meaning of my post!
     
  2. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #2
    Call for a 3rd battery. If that doesn't work, it's probably the logicboard. Either way, I sure hope it's covered under warranty!
     
  3. byeehaaw macrumors 6502

    Joined:
    May 7, 2007
    Location:
    New York, NY
    #3
    maybe if you complain just maybe you'll get an upgrade instead of just another battery or the replacement of the logic board ;). haha ive heard some stories before. hope things work out
     

Share This Page