mdnsresponder and configd

Discussion in 'macOS' started by SolRayz, Dec 29, 2007.

  1. SolRayz macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #1
    Everytime I boot up now I recieve these annoying messages that say
    and
    If I click on deny on both I have no inernet connection. Also if I go to System Preferences and set my Firewall to "receive all incoming connections" essentually turning my firewall off these messages stop occuring on reboot.
    I think this all happened after trying to recalibrate my MBP battery but I am not sure.
    Anyone have any ideas?
     
  2. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #2
    I assume you are on Leopard? Did it come pre-installed and if not how did you install it?
     
  3. SolRayz thread starter macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
  4. SolRayz thread starter macrumors 6502a

    SolRayz

    Joined:
    Jul 5, 2007
    Location:
    Ft. Lauderdale
    #4
    I also noticed that when I reboot it doesn't remember my wifi connection. Anyone?
     
  5. bearda macrumors 6502

    Joined:
    Dec 2, 2005
    Location:
    Germantown, MD
    #5
    Same problem here under Leopard. If I don't allow it I don't get a good IP from my router (UI get one of the 169.x self-assigned IPs), though, and the connection fails. Real annoying.
     
  6. quasinormal macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    Sydney, Australia.
    #6
    I get exactly the same. Mine started after i took out the battery of my G4 Powerbook running 10.5.2, to clean the screen and keyboard.
     
  7. interconnect macrumors regular

    interconnect

    Joined:
    Nov 15, 2007
    #7
    same exact issue here.. i randomly started getting the messages.. i think they started appearing after a recent update. it also forgot my wireless connection, which i just retyped in my password and was all set there, although i still keep getting the prompts when i boot-up. i tried clearing out all the programs listed in the allowed application list and restarting in which neither mdnsresponder or configd were added and still continue to prompt me when i boot-up/login. i also had qmasterd doing the same thing, but went away after i cleared the allowed applications list and hasn't prompted me since for that one.
     
  8. MacMedic macrumors member

    MacMedic

    Joined:
    Oct 18, 2007
    Location:
    London, ON
    #8
    Me too suddenly

    All of a sudden I am getting those same two messages every time I boot to Leopard. There was a security update that I just applied today, maybe from that? I have also had it occasionally forget my wireless connections over the past few weeks. Very annoying. Anybody figure out where these messages and forgetfulness came from?
     
  9. kaz219 macrumors member

    Joined:
    May 8, 2006
    #9
    Same here on a PowerBook with Leopard 10.5.2.
     
  10. junior77 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Michigan
    #10
    Same exact problem....happened when the battery went dead.

    The only way around it was to do a re-install. Hopefully, someone else here will post a real way to correct the problem from re-occurring again.

    Powerbook G4 w/10.5.2
     
  11. ElectricSheep macrumors 6502

    ElectricSheep

    Joined:
    Feb 18, 2004
    Location:
    Wilmington, DE
    #11
    It sounds like a bad Application Firewall configuration (missing the exceptions that allow configd, mDNSresponder, and racoon). Restore from the defaults:

    sudo cp /usr/libexec/ApplicationFirewall/com.apple.alf.plist /Library/Preferences/com.apple.alf.plist
     
  12. junior77 macrumors regular

    Joined:
    Jun 29, 2007
    Location:
    Michigan
    #12
    So, basically delete the plist file above and reboot/restart? I'll have to keep this in mind if it happens again.
     
  13. sarakarlsson macrumors newbie

    Joined:
    Sep 8, 2008
    #13
    Possible Solution

    Hi,
    I had the same problem with may Macbook Pro. Thanks for the hints I found here, yesterday, after two hours the problem was solved. Although I am not sure which one of the steps was the one that finally helped and wether the procedure is going to help others, here is what I did:

    1. Reset the com.apple.kerberos.kdc certificate as described in http://support.apple.com/kb/TS1245

    2. Delete the ApplicationFirewall Preferences (located in Library/Preferences/com.apple.alf.plist)

    3. Allow the system processes mdnsresponder, configd and racoon in the firewall (click "plus", then alt-shift-g to access the system processes, then write /usr/sbin, then choose the three processes, add)

    4. As I run Little Snitch, I did two additional things: Allow these processes in Little Snitch as well

    5. Update from Litte Snitch 2.0.1 to 2.0.4

    Reboot after every step. After one of the first steps, the internet connection worked well, but the questions to allow the processes remained. After the modifications with Little Snitch, everything was fine again.

    Hope it helps someone else as well.

    Cheers Sara
     
  14. baronerosso macrumors newbie

    Joined:
    Jan 5, 2009
    #14
    HI,
    I solved with a custom com.apple.alf.plist.

    You have to delete all items in exceptions key and add child to firewall key with configd, mDNSresponder, racoon, ntpd and krb5kdc.

    I uploaded to Mediafire a zip with the corrected .plist and an Apple script with its source for newbies.

    http://www.mediafire.com/?1cmyjzvrnqk
     
  15. deadpoolio macrumors newbie

    Joined:
    May 31, 2010
    #15
    Band Aid fix for me.

    Hi guys. I was not able to connect my MacBook to the internet because of this mdnsresponder issue. Airport found my wireless network connection, but would fail to connect because there was no internet connection. Very frustrating and confusing. After using my PC to search the internet for solutions and idea's I did the following steps and my MacBook is connecting to the internet now.

    Go to:
    System Preferences- Security- Click the Firewall tab- Select "Allow only essential services"- Select Safari in the Application window- Delete Safari from the list

    Now follow the same instructions as above only this time Add Safari to the list.

    I've been able the connect most of the time since. I have to do this once in a while, but I'm just happy to be able to go online now. I suppose this means my problem has to do with something with the Firewall. I'll keep trying idea's.

    Note, as might be evident, I'm not a computer wiz. These are just the exact steps I did when the problem was fixed. I hope this helps others with the same problem.
     
  16. stokeyite macrumors newbie

    Joined:
    Mar 25, 2008
    #16
    deleting the firewall plist worked for me - thank you

    The battery on my powerbook G4 (10.5.8) went flat, and there were a number of problems on restarting with connecting to the internet. first I had to reset the time before the keychain would give the wifi password to the airport. Then it would not connect to the internet: message - self assigned IP address. Trying to renew the DHCP lease did not work - I think the firewall had started blocking something. But deleting the system level firewall plist [ /Library/Preferences/com.apple.alf.plist ] - as mentioned above and restarting solved the problem completely. So many thanks for the suggestion! :):)

    (By the way, if you want the firewall turned on again properly after doing this you do, of course, need to go to system preferences> security > firewall and [in leopard] select either allow only essential services or give permission to specific applications.)
     
  17. evanavevan macrumors member

    evanavevan

    Joined:
    Jun 24, 2010
    #17
    This just happened to my wife's computer and this seems to have worked great
     
  18. shingfai macrumors newbie

    Joined:
    Nov 23, 2010
    #18
  19. paulinpgh macrumors newbie

    Joined:
    Mar 12, 2011
    #19
    I had a similar problem. My battery went dead on my Mac 10.6.6 (snow leopard) laptop. After reboot, I my preferred network was not available (it lost my saved password) and I had 4 firewall errors asking to accept incoming connections from krb5kdc, mDNSResponder, nmbd, and xgridcontrollerd. Also, my clock was set to Dec 31st, 2000!

    I solved it by making a backup of /Library/Preferences/com.apple.alf.plist and deleting the original. Then I restarted my computer.

    Upon reboot, I did not get the several firewall dialog boxes asking to accept or deny the various connections. BUT, I still was being asked to enter my password for my network even though I entered it and was surfing the web before the restart. So, I entered it once again and then restarted computer. After restart, I was automatically connected to network. Problem solved (hopefully ;)

    Thank you everybody for your help and advice in this column.
     
  20. shamino, Mar 24, 2011
    Last edited: Mar 24, 2011

    shamino macrumors 68040

    shamino

    Joined:
    Jan 7, 2004
    Location:
    Purcellville, VA
    #20
    I'm seeing the same thing on an iBook G4 running Leopard. I removed the battery in order to fix a problem with my built-in audio device disappearing and now the firewall keeps on blocking configd and mDNSResponder, forcing me to allow them (and enter admin passwords) every time I reboot.
    This almost worked for me. With these changes, it no longer asked about configd, but it still asked about mDNSResponder. The fix for me was (in the firewall/mDNSResponder/proc key) to provide the full path - /usr/sbin/mDNSResponder. Then the system stopped asking me. I don't know why I needed it and you didn't.

    Thanks for your help. The other solutions have not done anything for me.

    The Leopard firewall is real junk. I much preferred the one from 10.4 that was based on ports instead of apps.

    And for those who may be unaware, it is really critical to install the developer tools on any Mac. The plist editor makes this easy. It would be a real nightmare to edit the binary-form plists without it.
     

Share This Page