MDS and MDWorker Bogging Down Leopard

Discussion in 'macOS' started by Shanesan, Nov 1, 2007.

  1. Shanesan macrumors 6502

    Shanesan

    Joined:
    Jul 29, 2006
    #1
    According to activity monitory, MDS was using 110% of my processing speed, and MDWorker was running at around 30%. What do these programs do, and why must they suck processing speed?

    UPDATE: It's spotlight reindexing. Nevermind. :)
     

    Attached Files:

  2. shaggy.mac macrumors newbie

    Joined:
    Apr 8, 2008
    #2
    Hey

    I have a similar problem with the GM build of Leopard.

    MDSWorker is using 110%
    ATSServer is using 64%
    MDS is using close to 0%

    What gives? I've had Spotlight index the drive and now it wants to reindex every 2 days!
     
  3. ntraft macrumors newbie

    Joined:
    Mar 3, 2008
    #3
    Well that's not normal, and something you may want to be concerned about, but first consider: How many documents/pictures do you write/download/move per day? And even more importantly, are you often installing/uninstalling new software? As I understand it, these are the things which cause Meta Data Worker to run for long periods of time.

    I don't know why Apple can't just tell the user what's going on with a little pop-up window that just has a progress bar and says, "Hey, just so you know, I'm going to go update this database now..." It would be much like Software Update. But that would make too much sense, I suppose.

    FYI, if you don't use Spotlight or Dashboard you can disable them. I've never done it, but it's supposed to be easy to find it on Google or Clusty if you just search "disable spotlight os x tiger".
     
  4. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #4
    Have you tried updating to 10.5.2? That fixed a hell of a lot of bugs from the original GM version.
     
  5. Bennieboy© macrumors 65816

    Bennieboy©

    Joined:
    Jan 15, 2009
    Location:
    england
    #5
    it would seem they havent fixed this, my cpu has just been having it, 90% usage on both cores, i've only got a 1Tb external and it's not doing nothing, it indexed the HD yesterday ( it makes a bit of a racket lol ) and it's been doing it again now,

    i dont suppose theres a way for it to be turned off or to edit any preferences on when it does it's job or not is there?
     

    Attached Files:

Share This Page