Megsafe cable on MBP 13" '11 not plugging in correctly?

Discussion in 'MacBook Pro' started by Trentolol, Aug 14, 2011.

  1. Trentolol macrumors member

    Trentolol

    Joined:
    Feb 1, 2011
    Location:
    Right here
    #1
    I went to plug in my cable for my computer in the Title.

    The cable doesn't go in snug. I can easily wiggle it around, although my battery keeps charging during the wiggling.

    Here are some pictures(sorry for crummy shots, had to use my 3GS)


    Should i be worried? Am I overreacting? Will it affect my battery's performance?

    Thanks for the help! You guys are the best!
     

    Attached Files:

  2. Dark Void macrumors 68030

    Dark Void

    Joined:
    Jun 1, 2011
    Location:
    Cimmerian End
    #2
    you can't reposition it to make it fit properly?
     
  3. Trentolol thread starter macrumors member

    Trentolol

    Joined:
    Feb 1, 2011
    Location:
    Right here
    #3
    No. Thats the problem. I can wiggle the megsafe around. I usually have to practically yank on it and it was a snug fit.
     
  4. Dark Void macrumors 68030

    Dark Void

    Joined:
    Jun 1, 2011
    Location:
    Cimmerian End
    #4
    I'm confused.

    You are saying that you cannot take it out and put it back in as to where it fits in properly, but you once could?

    It's probably just in there incorrectly, just take it out and try to be more accurate.
     
  5. Trentolol thread starter macrumors member

    Trentolol

    Joined:
    Feb 1, 2011
    Location:
    Right here
    #5
    When I first got my mbp, the megsafe had no extra room in the socket when the charger was plugged in. Today, I could wiggle it around a considerable amount. This worries me because it is no longer a snug fit.
     
  6. Dark Void macrumors 68030

    Dark Void

    Joined:
    Jun 1, 2011
    Location:
    Cimmerian End
    #6
    I still think it is your positioning ... I mean it's magnetic so you may think it's inserted but in reality it's just stuck to the port incorrectly. Neither the plug nor port have changed shape in the last few days, making it unable to fit like it used to, I promise.
     
  7. Trentolol thread starter macrumors member

    Trentolol

    Joined:
    Feb 1, 2011
    Location:
    Right here
    #7
    Okay, I will keep you updated!
     
  8. Kentochan macrumors 6502

    Kentochan

    Joined:
    Feb 19, 2011
    Location:
    Virginia, USA
    #8
    My 2011 13" MBP's MagSafe connector and port had been "wiggling" since I bought it. For me, the MagSafe port had never been a snug fit. But I can charge the MBP fine without any problems, so I don't think its too big of an issue.
     
  9. jimbo1mcm macrumors 68000

    Joined:
    Mar 21, 2010
    #9
    Problem coming

    IF its wiggling now you will have problems in the future. Take it to Apple and get it fixed.
     

Share This Page