Memory "lost" on wake up

Discussion in 'MacBook Pro' started by jwitte, Oct 16, 2010.

  1. jwitte macrumors newbie

    Joined:
    Jun 4, 2008
    #1
    Hi,

    HW: Macbook Pro early 2010

    Since a few weeks my Macbook Pro behaves a bit strange: It boots normally and both of my 2 2GB RAMs show up in "About this Mac" - I see 4GB. When I put the laptop in sleep mode and open it up again, the laptop occasionally doesn't come up again - the display stays black. When I press the power button for some time, the laptop comes back again but from hibernate mode. If I then open up "About this Mac" I just see 2GB. If I reboot, I either get 4 or 2GB - depending on the "mood" of the laptop. My question is: What can be the reason and how can I solve this?

    Thanks in advance
    Jochen
     
  2. ljonesj macrumors 6502a

    ljonesj

    Joined:
    Oct 20, 2009
    Location:
    Kingsport TN
    #2
    is this stock ram that came in the macbook or did you upgrade it yourself you may have to do a pram reset or the other one i cant remember
     
  3. jwitte thread starter macrumors newbie

    Joined:
    Jun 4, 2008
    #3
    Hi ljonesj,

    actually the problem first appeared with the original Apple RAM. I thought it would be an issue with the RAM and replaced it with 2x4GB chips, but the problem persisted. Then I removed one of the 4GB chips and since then the problem did not appear any longer. So it really seems to be a HW issue or? I will nevertheless try the pram reset...
     

Share This Page