memory problem.

Discussion in 'iOS Programming' started by larswik, Feb 11, 2014.

  1. larswik macrumors 68000

    Joined:
    Sep 8, 2006
    #1
    I am having a problem updating an app to ios7. Last time I worked with this app was with xcode 4.x last year. I am having an issue with objects not being retained. I started to work backwards through the code to figure out what was going on and using the debugger. In the image I attached you can see in the debugger that the NSMutableDictionary is nil.

    On line 83 I create the Dict. Online 84 I print the dict out which you can see the results of the NSLog in the lower right corner. Now the breakpoint is stopped on on line 85 where I grabbed the screen shot and you can see that the 'allCharacter" Dict is set to nil?

    How can this be, I just NSLog that Dict? If anything that dictionary object should have a retain count through the scope of this method?
     

    Attached Files:

  2. larswik thread starter macrumors 68000

    Joined:
    Sep 8, 2006
    #2
    Solved it. In the "Edit Scheme" the "Run" was set to Ad Hoc by mistake. I switched it to debug and that resolved the problem. That was my whole Tuesday.
     

Share This Page