Memory Upgrade from Crucial... Doesn't Work

Discussion in 'MacBook Pro' started by Dorv, Feb 13, 2008.

  1. Dorv macrumors regular

    Joined:
    Feb 11, 2008
    #1
    So I think I've always had pretty good luck with Crucial in the past, but seemingly not this time.

    I ordered 2 2gig sticks of ram for my new BlackBook. I used their memory advisor, and everything. They arrived today, and I couldn't get the machine to power on. I reseated the memory several times, switching the modules out, trying one at a time, etc, and couldn't get either to work.

    Replacing the original sticks got me up and running again.

    Do I have the right modules? The sticker says:

    2GB 200 PIN DDR2 SODIMM 256MX64

    Again, I have the 2.2 Black MacBook. I checked the invoice, and Crucial printed the information from the memory advisor, which checked out.
     
  2. taylorwilsdon macrumors 68000

    taylorwilsdon

    Joined:
    Nov 16, 2006
    Location:
    Bay Area
    #2
    Stuff happens. It sounds like you got some dead sticks.

    Just to be specific, you want:
    DDR2-667 PC2-5300 SO-DIMM

    Doesn't really need to be anything more or less then that. Try Newegg for some cheaper, non-broken RAM, or just RMA to Crucial.
     
  3. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #3
    Ok... things have happened that make me know its not the memory...

    I tried putting one of the 2gig'ers in with the 512. THAT worked. OSX showed me that I had 2.5 gigs of memory. So, then I tried the OTHER 2 gig with the 512, and that worked to.

    Now, I know upping the capacity on the Macbook was a (relatively?) recent change..

    What would cause my (four day old from Best Buy) unit not recognize BOTH sticks at the same time?
     
  4. taylorwilsdon macrumors 68000

    taylorwilsdon

    Joined:
    Nov 16, 2006
    Location:
    Bay Area
    #4
    Thats a conundrum. I would take the computer and all 4 sticks of RAM into your local Apple store and let them have a go at it. You should be able to whittle down the problem.
     
  5. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #5
    Looks like i have a project for the morning :)

    Thanks!
     
  6. mbrydone macrumors regular

    Joined:
    Jan 14, 2008
    #6
    if nothing else works can you return the memory to crucial???
     
  7. aneftp macrumors 68040

    Joined:
    Jul 28, 2007
    #7
    Did you buy the PC5300 SODIMM RAM. I believe the old PC2100/2700 DDR SODIMM RAM also contained to 200 pin but will not work with the newer DDR2RAM
     
  8. undaunted macrumors newbie

    Joined:
    Feb 14, 2008
    #8
    What a strange world we live in. I had EXACTLY the same thing happen to me today. I have a Santa Rosa 2 Macbook (black) MB063LL/B. Bought the same RAM from Crucial (2X2GB 667GHz DDR2 SODIMM 256X64 PC2-5300). Spent 5 hours on it this afternoon and came up with the same symptoms you did.

    I even called Crucial support. He did mention that they have been getting a lot of calls about these black macbooks. He mentioned that you have to ensure that the RAM is extremely well seated (really push it in) which I did.

    So I can't run all 4GB but I can run 1x2GB when I also have one of the original 512MB installed. Currently running at 2.5GB RAM. I ran the test (pressing D at startup with the disc) and it tells "no trouble found". Unfortunately I'm no where near an Apple store.

    I'm really interested to find out. Please please keep me posted!
     
  9. woody88 macrumors member

    Joined:
    Nov 29, 2006
    #9
    when the mac would not boot up, did it beep at you? I bought some of these 2gb sticks too. if you can get the upc number, please compare them with the ones I received, which has UPC of 649528733030. That may indicate something there. Hope that helps. I notice that I did not push mine down enough at all, which caused it not to boot up. Once I seated them correctly, it is smooth sailing from that point on.
     
  10. undaunted macrumors newbie

    Joined:
    Feb 14, 2008
    #10
    No sound at all. Just a black screen (but the light goes on). Where do I find the UPC? I have this number: CT25664AC667.16FE but I think that is a Crucial part number...

    Again, strange this is they do work and are recognized if they aren't solo or paired (1x2GB and 1X512MB works).
     
  11. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #11
    Went to the Apple Store today. Basically told me that they could take the machine in overnight to check the memory controllers, but based on the fact that both of the chips worked independently that he thought that the chips weren't matched (or paired, or whatever).

    So I called Crucial. They told me that the chips did match, and that it was most likely a firmware issue with my laptop (The laptop is five days old... The Firmware is updated, I double checked). He said at first glance that they had no other chips that could work, but he eventually found me another set that they are (Hopefully) overnighting to me for delivery tomorrow (I'm traveling starting Sunday for the next two weeks).

    I'm a little frustrated by the whole process. I went with Crucial, despite being a little more expensive, because of the perceived quality bump. Its not a seating issue, as I've put them in and out several times (as did my local Genius), and have been able to seat them with 512 chip easily. They are the PC2-5300 that someone asked about....

    I don't see a UPC either... here are all of the numbers on the sticker:

    Lot Number: BL1116D.21
    CT25664AC667.16FE
    2 GB 200PIN DDR2 SODIMM256X64 (The packaging includes the PC2-5300 number after that, but not on the sticker)
    200801 MT
    77463

    Updates continue...
     
  12. dodge2112 macrumors newbie

    Joined:
    Feb 14, 2008
    #12
    Yes... very small world. I have just gone through the exact same thing for the past four hours! It has to be something with Crucial's memory. Any solution oriented info that anyone has would be greatly appreciated.
     
  13. CanadaRAM macrumors G5

    CanadaRAM

    Joined:
    Oct 11, 2004
    Location:
    On the Left Coast - Victoria BC Canada
    #13
    As mentioned, it is VERY common for RAM not to work in MacBooks and iMac Intels, because of the socket design. You push the RAM in about 1 inch and it stops. You are not done yet. You have to get both thumbs on the edge of the RAM and push it in another 1/8 inch (2mm) to seat the contacts fully into the socket.

    The Apple original RAM has a lubricant on it to help make it easier to assemble.

    The "Black screen and just the power light pulsing" is the classic symptom.
     
  14. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #14
    Crucial was able to get the new memory out today, so I'll have it tomorrow. Will share the results. Hopefully it will arrive before I got to work at 3:00p
     
  15. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #15
    Canada: While I definitely had some issues getting the RAM in, I know that I've (and the other poster) have it in because we can get one at a time working, but not both... Hopefully this resolution from Crucial with a different type will be the resolution.
     
  16. dodge2112 macrumors newbie

    Joined:
    Feb 14, 2008
  17. undaunted macrumors newbie

    Joined:
    Feb 14, 2008
    #17
    Dorv: Holding my breath before I call Crucial back to see if your new memory actually works (also fingers crossed). Thanks for keeping us updated.
     
  18. southerndoc macrumors 6502a

    southerndoc

    Joined:
    May 15, 2006
    Location:
    USA
    #18
    That's odd because I ordered my memory from Crucial recently.

    Purchased a black MacBook from the Apple Store on 9 February. Ordered 2 2GB DDR2 PC2-5300 sticks on 9 February with overnight delivery, which shipped on the 11th and was received on the 12th.

    Popped them in and haven't had a single problem with them. The computer recognizes all 4 GB (the other thread mentioned something about a 3.3 GB limit - not sure about that since all memory is recognized).

    I ensured that the memory sticks were well seated by pushing on them pretty firmly.

    Have you tried reinserting both sticks again?
     
  19. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #19
    Yeah, I've inserted them/reinserted them every which way. I know that I'm seating them properly because if I take out one and put in the 512 stick, it works just fine.

    Based on the note from the MOD in the other thread, I'd suggest using this thread instead of the other.

    Looks like there's three of us that are having the exact same problem, all having ordered the same product from the same company, and one poster who's installed the same without issue.

    I have faith in Crucial will get me a product that works. I'm hoping UPS comes soon, as I'm at work now, and my apartment office is only open until six. If it doesn't come before that, I'm out of town for the next two weeks, and won't be able to get it from the office until I get back :(
     
  20. woody88 macrumors member

    Joined:
    Nov 29, 2006
    #20
    Good luck Dorv, please let us know if it works for you. Mine works just fine, and I got the UPC from the package, and not off the RAM, so maybe you can check it out that way?
     
  21. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #21
    Woody: Those numbers were from the package... It didn't have a UPC (at least not one that I recognized as such).

    Ok: New stuff just got in. From the packaging:

    2 BG 200PIN DDR2 SODIMM 256MX64 PC2-5300
    UPC: 49528 73303
    79345
    BL1115Y.85
    CT25664AC667.M16FE

    The sticker on the memory still indicates that its made by Crucial, so no third party stuff.

    Lets see if it installs...
     
  22. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #22
    Boo-Ya....

    Success!!!

    System Info shows a nice 4 gigs of RAM.

    The only other difference of note that I can tell is that the newer (Replacement) ram had its packaging information printed on a dayglo orange label while the original memory was printed onto the static resistant (?... Resistant or protected?) packaging.
     
  23. undaunted macrumors newbie

    Joined:
    Feb 14, 2008
    #23
    Awesome Dorv! I'm calling Crucial back. Did you let them know that these ones worked? These ones must be from another manufacturer. Do you have any details on what's different???
     
  24. Dorv thread starter macrumors regular

    Joined:
    Feb 11, 2008
    #24
    I've provided all of the info. They were still of Crucial manufacture.
     
  25. undaunted macrumors newbie

    Joined:
    Feb 14, 2008
    #25
    I've order an exchange from Crucial this morning. I'll let you know if it works for me.

    Incidentally the support person told me Crucial suspects that this issue is a result of a conflict between the video memory and those memory sockets on the Santa Rosa Macbooks and that Apple is already beta testing a firmware update (which should be released soon). Anyone else hear this?
     

Share This Page