Menu bar disappears

Discussion in 'macOS' started by tibelino, Apr 18, 2011.

  1. tibelino, Apr 18, 2011
    Last edited: Apr 18, 2011

    tibelino macrumors newbie

    Joined:
    Apr 18, 2011
    #1
    Hi everyone, this is my first post after years as a macrumors reader... I really can't get out of the following situation.
    Recently when i try to activate File Sharing the top menu bar disappears and I can only force shutdown my mac.
    Here's how it goes: I click System preferences-> Sharing -> File Sharing-> "+" button to add a shared folder.
    Whatever folder I'll choose, it won't appear in the list of shared folders plus after closing the system preferences window the top menu bar will disappear completely. Then the mouse won't be able to click, the keyboard won't respond (except for putting the mac mini to sleep with ctrl+alt+eject).
    Then the only way to restart is for me to force shutdown the machine.
    Operating system 10.5.8, Mac mini from august 2007 with 2 gb ram.

    Thanks to anyone who will help me, I can't have a shared network anymore!
    /Marco
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    I think you can use cmd+option+escape to bring up the force quit window, pick finder and pick relaunch instead of rebooting. I suggest you try creating another user account (also admin) and log out and log in as the new test account. Try sharing something from the test account. NOTE: Whatever you do, never share your entire Macintosh HD. Only share stuff that is underneath your own home folder or you run the chance of having the system automatically change permissions on files and folders (to allow sharing) that cause more problems later.
     
  3. tibelino thread starter macrumors newbie

    Joined:
    Apr 18, 2011
    #3
    Hi again,
    if I use the force quit window the finder is not listed, so i can't relaunch it.
    Currently the only way I found to experiment without force quitting every time is to activate the "request pasword on wake up" option.
    So whenever I get the half-crash issue I put the mac to sleep, wake it and then click on the only button that responds to click: "Switch user...".
    Then from the switch user window I can restart.
    I also tried creating a new Admin account but the problem keeps showing up.
    I'm starting to think about a complete backup + reinstall.
    I tried to repair permission, run maintenance script, downloaded the last combo Leopard update package and install it but nothing seems to help.
    By the way thanks for the tip about sharing folders only under my Home.
     

Share This Page