Menu Bar issue

Discussion in 'OS X Mavericks (10.9)' started by abcdefghijklmno, Jan 2, 2014.

  1. abcdefghijklmno macrumors member

    Joined:
    Apr 9, 2010
    #1
    Hi

    Recently (although I cannot pin down when) the menu bar has been behaving oddly. Many of the usual icons are missing/invisible (OS X standard ones), but the functionality remains and the icons are visible when clicked.

    (Hopefully screenshots can help explain this a little)

    Any suggestions? Have tried deleting ~/Library/Preferences/com.apple.systemuiserver.plist and restarting, no success.

    Ta

    A
     

    Attached Files:

  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    Mavericks caches plist files, so it will come back after a delete unless you reboot. So delete that plist again and reboot and see what that does.

    Do you have any menu bar modification utilities running?

    If it still does this after the plist delete, try a boot to safe mode and see if it still happens. Safe mode stops any login/startup items from running, so that tells you if lone of your login items is causing the problem.
     
  3. abcdefghijklmno thread starter macrumors member

    Joined:
    Apr 9, 2010
    #3
    Thanks. That seems to have resolved it. Here's what I did...

    • Delete all versions of ~/Library/Preferences/com.apple.systemuiserver.plist
    • Reboot. Menu bar stil misbehaving.
    • Reboot into safe boot. Delete ~/Library/Preferences/com.apple.systemuiserver.plist again.
    • Remove all startup/login items.
    • Reboot normally, now menu bar seems to be working

    :)

    A
     

Share This Page