Menu Blinking on Mavericks

Discussion in 'OS X Mavericks (10.9)' started by wadavison, Aug 25, 2013.

  1. wadavison macrumors newbie

    Joined:
    Aug 6, 2013
    #1
    Does anyone know how I would be able to stop my menu from blinking on Mavericks? It has happened in every developer preview and still hasn't been fixed, I've looked around and nobody else seems to have this issue on Mavericks. Here is an example of a guy fixing his on snow leopard but no longer works for Mavericks:http://www.youtube.com/watch?v=rAW69qZ29Aw

    Cheers,

    Will
     
  2. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #2
    What happens if you restart the menubar?

    Code:
    killall -KILL SystemUIServer
    Are you seeing anything strange in the console logs while the menu bar is blinking?

    /Applications/Utilities/Console.app

    What items do you have in the menubar? Any 3rd party menubar items?

    Does the same problem occur on a Guest account or new user account?

    Have you tried a fresh reinstall of Mavericks?

    Since nobody else has had this problem and posted about as you stated, my guess is it's either:
    a) Something corrupt in your first install that hasn't been changed since
    b) A third party app causing problems with Mavericks
     
  3. wadavison thread starter macrumors newbie

    Joined:
    Aug 6, 2013
    #3
    Thanks for the reply w0lf

    killall command did nothing.

    Guest account the menu was fine.

    Console produced this(sorry its ugly), assume it has something to do with iStat menu which is 3rd party(but I have uninstalled it):

    26/08/2013 12:42:30.065 pm WindowServer[15151]: CGXSetWindowListSystemAlpha: Invalid window 137 (index 0/1)
    26/08/2013 12:42:30.065 pm WindowServer[15151]: CGXSetWindowListSystemAlpha: Invalid window 138 (index 0/1)
    26/08/2013 12:42:30.075 pm SystemUIServer[15401]: MenuCracker 2.2 (/Library/Application Support/iStat local/extras/MenuCracker.menu)
    See http://sourceforge.net/projects/menucracker
    MenuCracker is now loaded. Ready to accept new menu extras.
    26/08/2013 12:42:30.075 pm SystemUIServer[15401]: failed to instantiate and get the principal class of bundle: NSBundle </Library/Application Support/iStat local/extras/MenuCracker.menu> (loaded)
    26/08/2013 12:42:30.082 pm SystemUIServer[15401]: MenuCracker: Allowing "iStatMenusCombined".
    26/08/2013 12:42:30.091 pm SystemUIServer[15401]: Could not load menu extra NSBundle </Library/Application Support/iStat local/extras/MenuCracker.menu> (loaded) for Class (null)
    26/08/2013 12:42:30.092 pm SystemUIServer[15401]: Cannot find executable for CFBundle 0x7fe41270d0a0 </System/Library/CoreServices/Menu Extras/Clock.menu> (not loaded)
    26/08/2013 12:42:30.106 pm SystemUIServer[15401]: Cannot find executable for CFBundle 0x7fe41270a150 </System/Library/CoreServices/Menu Extras/Battery.menu> (not loaded)
    26/08/2013 12:42:30.107 pm SystemUIServer[15401]: Cannot find executable for CFBundle 0x7fe412709730 </System/Library/CoreServices/Menu Extras/Volume.menu> (not loaded)
    26/08/2013 12:42:30.168 pm SystemUIServer[15401]: iStat Menus loading extra - combined
    26/08/2013 12:42:30.362 pm system_profiler[15403]: Error -536870198 (e00002ca) occurred reading DPCD register data in System Profiler.
    26/08/2013 12:42:30.524 pm system_profiler[15403]: Error -536870198 (e00002ca) occurred reading DPCD register data in System Profiler.
    26/08/2013 12:42:30.618 pm com.apple.launchd.peruser.501[186]: (com.apple.SystemUIServer.agent[15401]) Job appears to have crashed: Bus error: 10
    26/08/2013 12:42:30.618 pm com.apple.launchd.peruser.501[186]: (com.apple.SystemUIServer.agent) Throttling respawn: Will start in 10 seconds
    26/08/2013 12:42:30.769 pm ReportCrash[15394]: Saved crash report for SystemUIServer[15401] version 1.7 (392) to /Users/student/Library/Logs/DiagnosticReports/SystemUIServer_2013-08-26-124230_Wills-Macbook.crash
    26/08/2013 12:42:30.811 pm ReportCrash[15394]: Removing excessive log: file:///Users/student/Library/Logs/DiagnosticReports/SystemUIServer_2013-08-26-123902_Wills-Macbook.crash
     
  4. w0lf macrumors 65816

    w0lf

    Joined:
    Feb 16, 2013
    Location:
    USA
    #4
    Okay well looks like it is indeed a part of the 3rd party app iStat Menu causing the blinking. (Menucracker)

    Since you say it's already uninstalled try going to (in finder press Command + Shift + G then paste the line in and press return)

    Code:
    /Library/Application Support/
    and deleting all folders relating to iStat Menu in there also check

    Code:
    ~/Library/
    
    and
    
    ~/Library/Application Support/
    and delete anything that relates to iStat Menu

    Then restart.

    I would also HIGHLY recommend installing http://www.freemacsoft.net/appcleaner/ it will help prevent things like this from happening in the future and probably save you some space as almost all apps leave traces behind, most small but sometimes large. You could also reinstall iStat Menu and then simply use Appcleaner to remove iStat Menu and hopefully the junk it's leaving behind.

    Hopefully that works out for you.
     
  5. wadavison thread starter macrumors newbie

    Joined:
    Aug 6, 2013
    #5
    Thanks w0lf, reinstalled a new version of iStat and it fixed itself straight away.

    I had appcleaner previously but didn't like it, felt it's UI wasn't as straightforward as it could've been.

    Looked at it again and will give it another go, looks slightly different.

    Thanks for your help
     
  6. don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #6
    Mavericks -- now with flashing menu bar

    Installed Mavericks yesterday, and now I'm having the flashing menubar problem described above.
    It appears when I take anything full-screen -- Steam games, youtube videos, quicklook, etc.
    This flashing distraction is totally exacerbating my "kill all humans" syndrome.

    I had iStat Menus running, but I uninstalled (and deleted related files) and restarted.
    The menubar now flashes slightly less frequently, but it still flashes.

    Other menubar items include Spectacle, Frank DeLoupe, Caffeine, Degrees, Typinator, Drive Genius DrivePulse, and Intego Net Barrier.

    In the console, I get this set of lines constantly repeating:

    10/23/13 2:06:15.587 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor[7432]) Suspicious setup: User "appserver" maps to user: _appserver
    10/23/13 2:06:15.874 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd[7464]) Suspicious setup: User "appserver" maps to user: _appserver
    10/23/13 2:06:15.952 PM WindowServer[193]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x118118, securitySessionID=0x186a6, err=-600
    10/23/13 2:06:16.336 PM WindowServer[193]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x119119, securitySessionID=0x186a6, err=-600
    10/23/13 2:06:16.407 PM WindowServer[193]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x118118, securitySessionID=0x186a6, err=-600
    10/23/13 2:06:16.714 PM WindowServer[193]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x119119, securitySessionID=0x186a6, err=-600
    10/23/13 2:06:17.788 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor[7432]) Exited with code: 1
    10/23/13 2:06:17.788 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor) Throttling respawn: Will start in 8 seconds
    10/23/13 2:06:18.121 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd[7464]) Exited with code: 1
    10/23/13 2:06:18.121 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd) Throttling respawn: Will start in 8 seconds


    Any suggestions for a fix would be greatly appreciated.
     
  7. meme1255 macrumors 6502

    Joined:
    Jul 15, 2012
    Location:
    Czech Republic
    #7
    Try to find software which uses Menucracker from list above. That's probably the cause of problem :( - I'm temporary using MenuMeters instead of iStat menus :)
     
  8. don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #8
    Can't find Menucracker in console

    Can't find Menucracker in console, but I turned off all extra menubar items except DrivePulse and Intego.
    They're next to go.

    In the meantime, I found this in the loop:

    10/23/13 2:20:58.043 PM com.apple.SecurityServer[15]: Session 100004 created
    10/23/13 2:20:59.253 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor[896]) Suspicious setup: User "appserver" maps to user: _appserver
    10/23/13 2:20:59.296 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd[924]) Suspicious setup: User "appserver" maps to user: _appserver
    10/23/13 2:20:59.414 PM Console[932]: setPresentationOptions called with NSApplicationPresentationFullScreen when there is no visible fullscreen window; this call will be ignored.
    10/23/13 2:20:59.823 PM WindowServer[234]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x3f03f, securitySessionID=0x186a6, err=-600
    10/23/13 2:20:59.837 PM WindowServer[234]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x40040, securitySessionID=0x186a6, err=-600
    10/23/13 2:21:00.396 PM WindowServer[234]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x3f03f, securitySessionID=0x186a6, err=-600
    10/23/13 2:21:00.409 PM WindowServer[234]: [cps/setfront] Failed setting the front application to bin, psn 0x0-0x40040, securitySessionID=0x186a6, err=-600
    10/23/13 2:21:01.937 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor[896]) Exited with code: 1
    10/23/13 2:21:01.937 PM com.apple.launchd[1]: (com.apple.webobjects.womonitor) Throttling respawn: Will start in 8 seconds
    10/23/13 2:21:01.969 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd[924]) Exited with code: 1
    10/23/13 2:21:01.969 PM com.apple.launchd[1]: (com.apple.webobjects.wotaskd) Throttling respawn: Will start in 8 seconds


    Could it be a problem with NSApplicationPresentationFullScreen?
     
  9. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #9
    Have you tried resetting the pram. I had an issue like this in the dev previews and that fixed it for me. I have istatmenus on the gm and it's absolutely fine.
     
  10. don1138 macrumors newbie

    Joined:
    Oct 23, 2013
  11. justperry, Oct 23, 2013
    Last edited: Oct 23, 2013

    justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #11
    Log in with the shift key pressed (instantly press and hold the shift key after you hit enter), this will prevent any 3rd party software from loading, if it is still blinking it is not 3rd party software which causes this.

    Edit: You could also make a new user account in Users and groups, logout and into the new User and see what happens there.

    You SystemUiServer seems to be crashing, you can see this in Activity Monitor.
     
  12. madmacfan macrumors 6502

    Joined:
    Feb 19, 2012
    Location:
    London, United Kingdom
    #12
    Just had a thought. The menubar and menubar icons/apps are controlled by the systemuiserver, so if the pram has had no effect then resetting the system management controller (smc) may be the solution.
     
  13. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #13
    A restart in Safe mode could also help, this flushes Caches and might help.
     
  14. don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #14
    I made a new user -- no menubar flicker.
    Came back into main account -- flicker continues.

    So, in the short term, I can use the alt account when I need to, but the problem continues. I'll test the menu apps in the new account and post if I see anything interesting.

    BTW -- Any suggestions for how to keep the SystemUiServer from crashing? I've customized my machine so much -- webobjects frameworks and etc, etc -- I'd hate to have to do a clean install, but if that's what it takes…
     
  15. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #15
    As I said before, hold shift right after hitting the enter key when you log into your normal account, it should be OK then, if so, go into Users and groups, make a screenshot what is there, then delete all the login items and see if this solved the problem, if so add the programs one by one until the problem re occurs, this way you know the offending App.
     
  16. don1138, Oct 24, 2013
    Last edited: Oct 25, 2013

    don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #16
    I pulled out all the menubar apps, but the problem persists.

    The alt account I made was bug-free, until I re-installed Civ V, and then the menu flicker started appearing in that setup as well.

    Forgive me for a bit of frustration-related snark, but I'm starting to suspect Maverick is a freebie because of bugs like this.
     
  17. AquaMethod, Oct 26, 2013
    Last edited: Oct 26, 2013

    AquaMethod macrumors member

    Joined:
    Jun 17, 2008
    #17
    I've seen this after unplugging a second display. Each app gets corrupted and needs to be relaunched. You'll see these lines in the Console:

    Code:
    2013/10/26 16:42:42.578 Finder[15326]: CGSCopyDisplayUUID: Invalid display 0x440427c3
    
    If you relaunch the app (this includes the Finder) the bar should stop blinking when that app's menu bar is displayed.

    Is that what's happening for you?
     
  18. GenBison macrumors newbie

    Joined:
    Oct 31, 2013
    #18
    Hi just registered here because I'm having the same problem with Mavericks and it's driving me mad.

    Getting constant and annoying mini-hangups with the mouse and the console is littered with these types of alerts for every app and program nameable - mostly when they are active but not exclusively.

    Needless to say I have already re-started the computer with no effect, I have also re-set PRAM and SMC which doesn't seem to help.

    Since my last re-install the only items I run on startup are:
    iTunes Helper
    WiFi Signal (app store app)
    Activity Monitor (apple)
    Dropbox

    This is a small snapshot of the number and frequency of errors (note the times!) I have pages & pages of them if anyone need to see the lot!

    No one else seems to be having this so I'm very glad to find some evidence somewhere else about the Invalid Display message.

    Specs:
    MBP 13-inch, Mid 2012
    2.9GHz Intel Core i7
    8GB 1600 MHz DDR3
    Intel HD Graphics 4000 1024 MB
    Mavericks 10.9 (with all latest updates)

    Also running a Samsung 1080p Monitor through the Thunderport using Moshi Adapter. Apple Bluetooth Keyboard and TeckNet Cordless Mouse.

    To my knowledge I do not have iStat Menu or Menucracker so they may not be the root of the problem. Hope someone can help!

    Sorry for the massive post...
     
  19. GenBison macrumors newbie

    Joined:
    Oct 31, 2013
    #19
    Update:

    Just been going back through the logs, also found reference to NSApplicationPresentationFullScreen which I believe don1138 also had.

    FYI
     
  20. Earendil macrumors 68000

    Earendil

    Joined:
    Oct 27, 2003
    Location:
    Washington
    #20
    Has anyone resolved this yet? I'm getting the same thing, but with the added bonus that no applications will launch either. When I try and launch one the finder crashes. A freshly created account has no issues.
    Holding down Shift (safe mode) and starting the problem account, and it continues to have issues.
     
  21. AquaMethod macrumors member

    Joined:
    Jun 17, 2008
    #21
    I found that fresh accounts tend to develop the issue over the course of an afternoon or a day. My guess is we'll have to wait for 10.9.1, sadly. I made the menu bar translucent again, as that reduces the effect, but it is still annoying!
     
  22. tentaclejoe macrumors newbie

    Joined:
    Nov 4, 2013
    #22
    My blinking problem seems to go away when I turn off my google drive syncing app. Returns right away when I fire it back up.
     
  23. don1138, Dec 3, 2013
    Last edited: Dec 4, 2013

    don1138 macrumors newbie

    Joined:
    Oct 23, 2013
    #23
    In the months since I installed Mavericks…

    • Menu blinks on and off in full-screen view in Quicklook, games, web videos, etc.
    • Menu doesn't seem to recognize mouse click until several tries.
    • Internet access is constantly dropping in and out. (Comcast assures me this is a Mac problem, and not one of theirs.)
    • And more…

    Hoping for a fix in the new update.
     
  24. sebast34 macrumors newbie

    Joined:
    Jan 16, 2014
    #24
    Chrome Notification

    It seems Chrome Notification Icon does this menu blink too.

    Remove it via chrome://flags
     
  25. costica1234 macrumors member

    Joined:
    May 21, 2013
    Location:
    London
    #25
    Sorry for bumping this thread ... :D

    I am also having a problem with my menu bar in Mavericks (which I actually noticed soon after installing the OS back in October), but it's not entirely related to this so-called "blinking". It happens that if I have a FULL-SCREEN window (I mean a window spanning between the Dock and the menu bar) and I play around with the 4 finger gestures (such as spreading out to show the desktop), then the border between the window and the Menu bar (which I suppose is a 1-2 pixels thick) will either blink or become transparent, giving the impression that there is no separation between the window and the menu bar ... Things get back to normal if I move to a new space or play around with the trackpad gestures. It's so weird. I was actually able to replicate this behaviour with a full-screen Safari window: I opened a new tab and after spreading out with thumb and 4 fingers to show the desktop and then rolled back, the thin line between the window "touching" the menu bar and the menu bar itself vanished ...

    I even uninstalled all menu bar applications, then rebooted, but with no success. However, when I log into the guest account there is absolutely no problem with the menu bar ...

    I mean it's something I can live with, but sometimes it annoys me. Any help is greatly appreciated. Thanks ;)
     

Share This Page