Menubar tweak gone awry. Can't access anything from GUI

Discussion in 'macOS' started by Vord, Sep 28, 2009.

  1. Vord macrumors newbie

    Joined:
    Sep 28, 2009
    #1
    Using these instructions
    http://www.aeroxp.org/board/index.php?showtopic=11720&st=0
    I was attempting to tweak the coloration of my menubar. (MBP OSX 10.6 Snow Leopard) After following the instructions and replacing the default SArtFile.bin and Extras2.rsrc, I rebooted and ran headlong into a brick wall. My menubar didn't come up at first at all; after attempting to launch finder, I got my menubar up, but I couldn't interact with it whatsoever. At this point, I tried bringing up finder again, and I received the error message "Application Finder can't launch" and an error message reading -10810.

    Realizing that I couldn't replace the two files with their respective backups (Which do exist on my desktop), I booted into single user mode and was going to attempt to replace them from there. The problem that I'm running into right now is that the directory location of the two files that need to be replaced are coming up as read only in Bash.

    Can anybody lend me a hand with this? If you can't figure out any way in which to restore the original files, backup help would be appreciated as well. I need to get the information off, but without being able to access anything inside of OSX without single user mode, it's kind of a problem.

    Any ideas?
     
  2. Vord thread starter macrumors newbie

    Joined:
    Sep 28, 2009
    #2
    Still completely at a loss here. Tried everything I can from chmod to grant write permissions down to trying to mount an external drive for backup. Nothing wants to work, I always run into the same "Read-only file system" error.

    Anybody have any experience with this?
     
  3. The General macrumors 601

    Joined:
    Jul 7, 2006
  4. PurrBall macrumors 65816

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #4
    You need to
    Code:
    fsck -fy
    and then
    Code:
    mount -uw /
    in single user mode in order to replace the files.
     

Share This Page