[MERGED] iPhone 7[/7+] camera lag

Discussion in 'iPhone' started by stuey12345, Sep 29, 2016.

  1. stuey12345 macrumors member

    Joined:
    Aug 22, 2013
    #1
    anyone else having a problem with iPhone 7 camera taking 20 seconds for app open?
     
  2. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #2
    Apps should always open as good as instantly. 20s is an issue. Contact apple for support. You get free phone support for 90 days or whatever.
     
  3. vanburen982 macrumors newbie

    Joined:
    Sep 18, 2016
    #3
    I used to have that problem on my 6S. Haven't seen it on my 7. Good luck.
     
  4. Relentless Power macrumors G5

    Relentless Power

    Joined:
    Jul 12, 2016
    #4
    20 seconds seems long to me. Mine is no where near that. Contact Apple support.
     
  5. erolsansolo macrumors newbie

    erolsansolo

    Joined:
    Oct 4, 2016
    #5
    This happens to all iphone 6S, 6S plus and 7 series. (I am a 6S user, this has been happening from day 1. - This is obviously a software issue Apple has yet to adress)

    https://origin-discussions-us.apple.com/thread/7669888?start=0&tstart=0

    citation from the thread:
    Iphone 7 - Camera freeze on the launch

    The native camera app of iphone 7 is taking 5-20 seconds to launch.

    To reproduce the issue:

    1) Open the native camera app.
    2) Close the native camera app by pressing a home button (important: do not delete the camera app from the recently used apps in multitasking).
    3) Make 5 calls or more, each call 1-10 sec duration or longer. E.g. call your voicemail to simulate a day calls.
    4) After making the calls, open the native camera app from the lockscreen.

    The video below demonstrates the issue:


    In this video it is 5 seconds freeze on iphone 7 (seen on 1:42 of the video). The camera freeze is related to the amount and duration of the calls, more calls - the longer it takes for camera to launch. The freeze can go up to 20 seconds.

    I experience this issue on iphone 7 (ios 10.0.1) and on iphone 6s (from ios 8 to ios 10).

    I have very strong reasons to believe, that all iphones 7 and 6s are affected by this bug and it can not be fixed by rebooting, resetting, DFU, new apple id or phone replacement: I tried to do all these steps many times with my iphone 6s and it did not help. This issue can be addressed only by Apple developers.

    Please submit this bug to Apple directly under the following link (as it seems that they do not react to our discussions forums): http://www.apple.com/feedback/iphone.html

    This thread is designated for iphone 7 and 7 plus.

    The same camera problems with iphone 6s are discussed in the following big thread since October 2015: iphone 6s camera lag https://discussions.apple.com/thread/7260874

    The purpose of this thread is to share and spread out the issue, as well as make Apple notice and react to the concerns of its users by fixing this bug.
     
  6. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #6
    Wow, the wife was going to buy a 7, I think she may have pause until this issue is vetted out
     
  7. Newtons Apple Suspended

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #7
    My camera on my 7+ opens pretty well instantly or as fast as any of my other apps.
     
  8. erolsansolo macrumors newbie

    erolsansolo

    Joined:
    Oct 4, 2016
    #8
    There is no reason not to buy the iphone 7, as this is not a new issue, and there is a workaround to it: double tap home button to bring up multitasking window and delete camera app from the recent list after every camera app use.

    When used this way, the native camera app will launch instantly everytime. We shouldnt be forced to using it this way but under the circumstances, this is the only sure way the camera will launch instantly when you need it.
     
  9. DJTaurus macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #9
    No please dont make petition to fix that bug. Apple gave me a refurbished 6S and sold it as new in the highest price in order to get iphone 7. Now my iphone 7 has the same bug (doesnt happen always) and i want that bug when i will get the iPhone 7S/8..... please dont fix it !!!! :p
     
  10. Benito macrumors 6502

    Benito

    Joined:
    Jan 5, 2010
    Location:
    Toronto, Canada
    #10
    Yes I get a delay at times when opening up the Camera app. As well, sometimes when I hold the phone in portrait and open the camera app, it opens upside down.

    Also, when swiping to open the camera app from the lockscreen, sometimes the lockscreen and the camera screen will both be halfway open rather than swiping all the way open.
     
  11. JT704 macrumors newbie

    Joined:
    Oct 17, 2012
    #11
    Lagging occasionally and sometimes just plain failing to open.
     
  12. TroyBoy30 macrumors 68000

    TroyBoy30

    Joined:
    Jun 9, 2009
    Location:
    Atlanta GA
    #12
    Happened to me yesterday. A good 20 seconds to be able to take a pic
     
  13. Stevo1006, Oct 4, 2016
    Last edited: Oct 4, 2016

    Stevo1006 macrumors member

    Joined:
    Sep 16, 2014
    #13
    Anyone else experiencing lag when opening camera stays on a blurred screen for roughly 5 seconds then camera is live.

    Not sure if it is a hardware problem or a software problem

    This is an intermittent problem
     
  14. jdblas69, Oct 4, 2016
    Last edited: Oct 4, 2016

    jdblas69 macrumors regular

    Joined:
    Aug 15, 2012
    #14
    No problem with mine. Usually opens up instantly if not a very slight delay certainly not 5 seconds though.

    Also wanted to mention I think it is software related. Noticed some other threads where people are having the same problem. Can't imagine there would be that high of a hardware failure rate. I would imagine when the update comes out for the portrait mode other camera issues will be addressed in the same update
     
  15. GobyRay macrumors newbie

    GobyRay

    Joined:
    Oct 4, 2016
    #15
    Yes, I am having the same problem. When I reboot the phone it seems to help for a period of time, but then it comes back. I have 3 days left before I can't return the phone back to Sprint so I'd like to know what the issue is.
     
  16. jfc723 macrumors newbie

    Joined:
    Jan 9, 2015
    #16
    anyone has a fix for the camera lag when opening the app?
     
  17. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
  18. jfc723 macrumors newbie

    Joined:
    Jan 9, 2015
    #18
     
  19. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #19
    My wife had this issue too. It's also slower to focus on the subject than previous phones. I just assumed this was by design and shrugged it off.
     
  20. Thor_1 macrumors 6502a

    Joined:
    Sep 18, 2016
    Location:
    Texas
  21. jfc723 macrumors newbie

    Joined:
    Jan 9, 2015
    #21
    Having the same issue in 5 different iphones ....

    2 iphones 7
    2 iphones 5s
    1 iphone 6

    the issues on the older phones started as soon as they were upgraded to ios10
     
  22. erolsansolo macrumors newbie

    erolsansolo

    Joined:
    Oct 4, 2016
    #22
    Problem officially solved by iOS 10.1 update. I can confirm with 2 different iphone 6S and a brand new iphone 7.
     

Share This Page