iPhone Message alert setting not working

SASRocks

macrumors newbie
Original poster
Jun 14, 2014
2
0
Hi all,

I am using iPhone 5s IOS 7.1.1 and was hoping to change my message notification setting so that I only receive an alert when I receive messages from someone in my contacts. I went into the Notification Centre -> Message and scrolled down to select "Show alerts from my contacts" rather than "Show alerts from everyone".

I thought this would do the trick. But this setting changed nothing - I used another number (which I deleted from my contacts) to send a message to myself and I am still getting alerts on the lock screen as well as the badge icon. Am I missing something here?

Any help would be greatly appreciated. Thanks!

Regards
QG
 

SASRocks

macrumors newbie
Original poster
Jun 14, 2014
2
0
That explains a lot. Thanks guys.

So I assume there is no way to do the same thing with SMS?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.