Message list only shows numbers, no names

Discussion in 'iPhone' started by andross77, Oct 31, 2011.

  1. andross77 macrumors regular

    Joined:
    Oct 11, 2011
    #1
    This just started happening to me literally an hour ago. I did restart my phone. Most of my text message threads are showing just the numbers and not the names. when i go into my contact list, they are the same as they have always been and i have the same number that is in the text message list (10 numbers, no parenthesis or dashes).

    I didn't change any of my contacts and i only altered some of my icloud syncing settings. but i didn't change contacts or mail in icloud.

    It looks like when i get a new text from someone it's showing up as their name (ie. making a separate text message thread so now i have 2 for each person...1 with their number and 1 with their name)

    I found a thread back in 2008 and 2009 where this was happening but didn't find anything recent (as in iOS 5.0). Anyone else?
     
  2. HiDEF macrumors 68000

    HiDEF

    Joined:
    Jun 23, 2010
    Location:
    Miami, FL
    #2
    Definitely sounds like an iCloud issue.

    Check your Address book on your computer, if everything is fine then it's iCloud not syncing properly.
     
  3. andross77 thread starter macrumors regular

    Joined:
    Oct 11, 2011
    #3
    thanks. how do you re-force an icloud sync? i don't see that option.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    Go into your contacts and push the sync button in the top left if after a minute or so u still have the same issue then remove/add the account again
     
  5. andross77 thread starter macrumors regular

    Joined:
    Oct 11, 2011
    #5
    ok so i just went into contacts and pushed the sync and then went into messages and it's the same thing (most threads are phone numbers, not names)

    so i should turn off the contacts in icloud and then turn it back on?
     
  6. andross77 thread starter macrumors regular

    Joined:
    Oct 11, 2011
    #6
    I just found another thread on the apple forums and this worked for me:

    Here is what to do:


    From your VZW iPhone:

    1) Open the Phone and dial *228. This is a Verizon over-the-air programming number.

    2) When the system answer press 1 for "Program or activate your phone"

    3) You should get a prompt stating something like "Settings updated." Wait for the call to disconnect.

    4) Open the Task Manager and kill the Phone, Message, and Contacts Applications

    5) Wait a few minutes.

    6) Open the Message App to verify the fix.


    If you are still broken, kill the Message App again, then reboot your phone.



    I didn't have to kill the message app again and reboot my phone. it just worked the first time.

    thanks! :)
     
  7. Ben52646 macrumors newbie

    Joined:
    Nov 20, 2011
    #7
    Here is the fix!!!

    Okay, here is how you fix this problem:

    STEP 1. First you have to dial *228 on your iPhone 4S. You should note that *228 is a Verizon over-the-air programming number.

    STEP 2. Wait for sometime until the system responds, then you have to press “1″ to “Program or activate your phone”.

    STEP 3. After sometime the system will say, “Settings updated”. Then you have to wait until the call disconnects.

    STEP 4. Now double click the Home Button of your iPhone 4S to open the Task Manager.

    STEP 5. Now close Phone, Message, and Contacts Applications on your iPhone 4S.

    STEP 6. After waiting for five minutes, open the Message App on your iPhone 4S to check the fix.

    That’s it. In this way you can fix iOS 5.0.1 contact bug on your iPhone 4S. If you are not able to fix this issue after using the above steps then again you have to close the Message App and restart your iPhone 4S. It is expected that soon Apple will release iOS 5.0.2 to fix this issue.
     
  8. ronbuckles, Feb 8, 2012
    Last edited: Feb 8, 2012

    ronbuckles macrumors newbie

    Joined:
    Feb 8, 2012
    #8
    Found a solution

    My 4s started doing this last week on a trip to NYC. I had added contacts from a map lookup that include the "+ 1" plus area code and number. None of my other contacts had included the "+1". It seems as soon as I did that, it made all the rest of the contact numbers not usable. I removed all the new "+1" telephone numbers and turned off all apps and did the *228 option 1 reboot like above and everything went back to normal. Good luck folks...
     

Share This Page