Message notification not appearing in email icon

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Thunderbird 1, Dec 1, 2014.

  1. Thunderbird 1 macrumors member

    Joined:
    Apr 19, 2014
    Location:
    Poole, UK
    #1
    Sorry folks but this is driving me crazy.

    I can't get the red message notification dot to appear in the mail icon on the home screen when an email has been received. However, if I click on the icon itself and click on the relevant gmail account, the number of new messages appears, the phone dings and if I go back to the main screen, the red notification indicator has appeared on the icon.

    The text message notification on the home screen works fine with the same settings. These are the email settings I have activated for email alerts:

    Show in notification center: ON
    Allow notifications: ON
    Badge app icon: ON
    Show in lock screen: ON
    Alert style when unlocked: Banner
    Show previous: ON

    These are the same settings I have on the text message settings and that seems to work fine.

    Any ideas anyone? Thanks.

    Phil
     
  2. xstamper macrumors newbie

    Joined:
    Dec 1, 2014
    #2
    It sounds like your phone isn't set up to automatically check for new emails. I believe doing this will help:

    Settings>Mail, Contacts, Calendars>Fetch New Data>Turn on

    At that point you can customize your preferences for retrieving emails.
     
  3. Thunderbird 1 thread starter macrumors member

    Joined:
    Apr 19, 2014
    Location:
    Poole, UK
    #3
    'FETCH' for both my gmail accounts is ticked (as opposed to 'Manual'). However, there is a note at the bottom of the screen as follows

    "The schedule below is used when push is off for applications that do not support push. For better battery life, fetch less frequently". The the ticked option was 'Manually'. Do you think this may be the problem. Surely email supports Push.

    Still confused.

    Phil
     
  4. EvoXOhio macrumors member

    Joined:
    Nov 20, 2014
    #4
    It's set to manually, which means that the Mail app won't check for email unless you open the app. You need to choose one of the timed intervals to have it automatically check for email. Choose 15 minutes to receive them the fastest.
     
  5. Thunderbird 1 thread starter macrumors member

    Joined:
    Apr 19, 2014
    Location:
    Poole, UK

Share This Page