Messages action gone for sending photos?

Discussion in 'iOS 11' started by Brammy, Sep 17, 2017.

  1. Brammy macrumors 68000

    Joined:
    Sep 17, 2008
    #1
    Apologies if this has been mentioned. My search fu is weak.

    On iO10, if I took a pic and wanted to send it via Messges, I would just tap the thumbnail in the Camera app, then choose Messages from the document picker and send the photo.

    It looks like that is gone now. I have to go into Messages, choose the photo, and send it that way.

    Or am I missing something obvious?
     
  2. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #2
    No issues here on my 7Plus. I see Messages, Mail, Notes and so on.
     
  3. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #3
    Huh, that is weird. On my 6+ and 12.9" I see Mail, notes, etc. Messages doesn't even show in the "other" section.
     
  4. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #4
    Thats really weird. Have you toggled iMessage? Maybe something got stuck.
     
  5. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #5
    Yep. It's weird it is on both devices. The 6+ never saw a beta until the GM.
     
  6. Mabus51 macrumors 65816

    Joined:
    Aug 16, 2007
    #6
    When you take a picture, you should see a thumbnail in the lower left side. Tap the thumbnail and you get the option to send via messages.

    In the photos app. Tap the square with the up arrow and you get the option to send via messages.

    In the messages app tap the camera icon and select the picture you want to send.

    I haven’t seen any difference in functionality with sending a picture from iOS 10 & 11. Other than the new thumbnail option that is.
     
  7. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #7
    As I said in the original post, this functionality is missing for whatever reason on my two devices. This is what I see. It does not show up on “more” either. 17457D9D-FD1B-4317-944D-22D4408BBD12.jpeg
     
  8. Mabus51 macrumors 65816

    Joined:
    Aug 16, 2007
    #8
    If you’re in the messages app, you tap the camera like you did before in iOS 10. Your pictures all show up with the ability to take a new picture as well.
     

    Attached Files:

  9. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #9
    yah, that works.

    It just throw me off mentally since a lot of time I take a pic/video with the intent of sending it to my GF. I’m so used to the camera-thumbnail-messages action. I’m going to be getting an iPhone 8 soon, so I’ll just see if the clean build fixes it there.
     
  10. Mabus51 macrumors 65816

    Joined:
    Aug 16, 2007
    #10
    This is how it works now and has been since iOS 10. I don’t believe they’ll change it for a few more iterations so maybe in iOS 15 or so.
     
  11. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #11
    Right. I think we ar talking about the same thing.

    On iOS 10, I would take a picture. Then in the camera app, taps the thumbnail, and choose Messages from the action menu.

    For whatever reason, on iOS 11 the Messages action is missing from my actions menu. My gut feeling is a wipe and install might fix it. Or since it is missing on both of my devices, maybe it is just a weird iCloud error.

    Adding via the Messages app does work. It’s just not the muscle memory I have.
     
  12. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #12
    So, I may have sorted it out. I installed the MaaS360 profile for work this week. I bet they blocked it through that.
     
  13. Fantasigraphic macrumors 65816

    Joined:
    Mar 25, 2009
    Location:
    TN
    #13
    In Settings -> Messages is iMessages turned on and activated? Maybe toggle off the reboot phone and turn back on, let activate and try.

    Mine works fine after taking pic and from camera and selecting pic, then up arrow box, and messages
     
  14. Chazzle macrumors 68000

    Chazzle

    Joined:
    Jul 17, 2015
    #14
    It’s your MDM Profile. That caused the same issue for lots of beta testers. The profiles need to be updated for iOS 11.
     
  15. Brammy thread starter macrumors 68000

    Joined:
    Sep 17, 2008
    #15
    yeah, that's the case. I pulled the MDM profile and it worked.
     

Share This Page

14 September 17, 2017