Messages and autocorrection of spelling?

Discussion in 'macOS Sierra (10.12)' started by KoolAid-Drink, Feb 2, 2017.

  1. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #1
    I have autocorrect of words/spelling turned off. It works in every app except for Messages. Can anyone else confirm they have the same problem in Messages?
     
  2. MacGizmo macrumors 65816

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #2
    Not having that problem here. Turning it off in the System Keyboard prefs turns it off in Messages—don't even need to restart messages, just exit and enter a new text entry box to "refresh" the setting.

    I am running the latest Sierra beta though, so maybe it's a bug that's been fixed. Maybe someone else can confirm/deny using the regular shipping OS version.
     
  3. KoolAid-Drink thread starter macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #3
    Thanks, MacGizmo. I'm on the latest stable version (10.12.3) - in System Preferences > Keyboard, I have "Correct spelling automatically" unchecked, and every other app honors this setting. In Messages, words are autocorrected. I have checked and then unchecked this setting, with Messages closed, to no avail. I tested this. It's been that way since 10.12.0, and was niggling at my nerves, but I finally found the time to write about it here.

    Can someone with a stable, non-beta 10.12.3 (or lesser 10.12 version) confirm if they have the same issue? If it helps, I'm using English as the only language on my computer.
     

Share This Page