Messages.app crashes on startup

Discussion in 'OS X Yosemite (10.10)' started by PsykX, Jun 2, 2014.

  1. PsykX, Jun 2, 2014
    Last edited: Jun 2, 2014

    PsykX macrumors 6502a

    PsykX

    Joined:
    Sep 16, 2006
    #1
    For those of you like me who can't even test this amazing SMS feature because the app crashes on start...


    Back up all data.
    Quit Messages if it’s running.

    Step 1
    Hold down the option key and select Go ▹ Library from the Finder menu bar. Delete the following items from the Library folder (sometimes it may not exist):
    Caches/com.apple.Messages
    Leave the Library folder open. Try Messages again. If it works now, stop here. Close the Library folder.

    Step 2
    If you still have problems, quit Messages again. Go back to the Finder and move the following item from the open /Library/ folder to the Desktop:
    Messages
    (Note: you are not moving the Messages application. You’re moving a folder named “Messages.”)
    Test. If Messages now works, delete the Messages folder on the Desktop. Otherwise, quit Messages again. Put back the folder you moved, overwriting the newer one that may have been created in its place, and continue.

    Step 3
    In the Preferences subfolder, there may be several files having names that begin with "com.apple.iChat". Move them all to the Desktop.
    Also in the Preferences folder, there's a subfolder named "ByHost". Open it and do the same thing.

    Test again. This time Messages should perform normally, but your settings will be lost. You may be able to put back some of the files you moved to the Desktop in this step. Relaunch and test after each one. Eventually you should find one or more that causes Messages to malfunction. Delete those files and recreate whatever settings they contained.

    If the issue is still not resolved, quit Messages again and put all the items you moved to the Desktop back where they were. You don’t need to replace the files you deleted in step 1. Stop here and post again.

    If you later decide that you don’t like the results of steps 2 and 3, you can undo them completely by quitting Messages and restoring the items you deleted in those steps from your backup.


    Source : https://discussions.apple.com/thread/4600732


    Although I spoke too fast. Now it says my database is being upgraded, but nothing seems to be happening. The progress bar is stuck at 0. I guess I found half of the solution, does anybody else have the other half ? :)
     
  2. VisheshSood macrumors newbie

    Joined:
    Jun 3, 2014
  3. irnchriz macrumors 65816

    irnchriz

    Joined:
    May 2, 2005
    Location:
    Scotland
    #3
    I did a clean install on a separate partition then configured messages. All works fine now.
     
  4. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #4
    Clean install here too and no issues with Messages. Works the same as it does in Mavericks.
     
  5. RedPenguinGB macrumors newbie

    Joined:
    Jun 3, 2014
    #5
    Ummm..... Can't find folders:
    ByHost
    com.apple.iChat
     
  6. ToxicBurrito macrumors newbie

    Joined:
    Jun 4, 2014
    #6
    I've figured off a solution that works for me.

    If you have iCloud turned on on your mac, try this :

    -Sign out from iCloud on your mac (note that sometimes the "Photos" checkbox is still selected. If so, uncheck it and sign out again)
    -Try starting out Messages again
    It worked for me now. If it does for you too, continue with this :
    -Configure messages to use your apple id
    -Start FaceTime as well and configure it to use your apple id
    -You can now log into iCloud again, but do not turn on keychain

    SMS messages consistently work for now. Calls however don't ever start.
     
  7. RedPenguinGB macrumors newbie

    Joined:
    Jun 3, 2014
  8. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
  9. RedPenguinGB macrumors newbie

    Joined:
    Jun 3, 2014
  10. PsykX thread starter macrumors 6502a

    PsykX

    Joined:
    Sep 16, 2006
    #10
    So if I uncheck "Contacts" in iCloud, I can finally start the Messenger app in OS X.
    It's not very practical ...

    I read that it may be possible that I have two cards defined as "me", and this is why it crashes. And coincidentally, I do have two cards. One I did myself, and the other one was my Facebook card. Both had the little person icon next to them. I am stuck in how to fix this.
     
  11. VisheshSood macrumors newbie

    Joined:
    Jun 3, 2014
    #11
    That worked for me :) Thank you!
     
  12. grzegorz914 macrumors newbie

    Joined:
    Jun 6, 2014
    #12
    Solution:

    Go to the contacts.app and delete from the phone position all illegal characters such as: **700, *, etc..
    Permitted are only numbers and the + sign

    regards
     
  13. PsykX thread starter macrumors 6502a

    PsykX

    Joined:
    Sep 16, 2006
    #13
    You are a KING. I remember how it was driving me mad in Mavericks.

    It also accepts sharp (#) and comma (,) characters for those that are wondering.
    Commas are used to add a pause when dialling, useful if you're dialling a phone extension.
     
  14. Bacalhau macrumors newbie

    Joined:
    Jun 7, 2014
    #14
    Worked!

    Thank you very much!! Amazing!! Give me a paypal account and I'll buy you beers! ;)
     
  15. rwon21 macrumors newbie

    Joined:
    Jul 1, 2015
    #15
    Hey all, apologies for reviving an old thread but this has been an ongoing problem on my iMac (i.e. color wheel comes up/"app not responding" when launching the messages app). I've just done a fresh update to v10.10.4 and none of the above solutions have worked, any other possible solutions? Thanks!
     
  16. makux macrumors newbie

    makux

    Joined:
    Dec 18, 2015
    #16
    OSX10.11.2 with new Macbook 12. Had this issue. Unchecking contacts worked. Other suggestions in this forum string did not. Dug deeper and found that unchecking gmail contacts from my gmail accounts under Contacts allows Messaging to work. A little more practical than turning off contacts completely but still annoying.
     
  17. jeremysamuel macrumors newbie

    jeremysamuel

    Joined:
    Mar 15, 2016
    #17
    OMG!! After all the stuffing around in the Library, turning off Gmail contacts worked!! Now THAT is a stupid bug!! How frustrating! Well, thank you for the solution :)
     

Share This Page