"Messages" app keeps intercepting texts when computer is asleep

Discussion in 'Mac Apps and Mac App Store' started by jman995x, Nov 26, 2013.

  1. jman995x macrumors regular

    Joined:
    Sep 8, 2007
    #1
    Hello,

    I keep shutting down "Messages" on my MBP because it keeps intercepting text messages from my friends (even when I'm not on it, the lid is closed and it's "asleep"). I've stood next to a couple of friends the other and asked them to text me and I didn't receive anything on my iPhone. Then, when I went to school then next day and awoke my MBP, there were their messages.

    Obviously "messages" intercepting texts while I'm not on my computer doesn't make me very happy.

    How can I get "Messages" to either leave the text on the server so that my iPhone gets it also, or how do I keep "Messages" from intercepting texts even when it is off and my computer is asleep?
     
  2. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #2
    The computer isn't (shouldn't be) "intercepting" anything. All iMessages are received on all devices. It sounds like you need to check your "Receive At" settings on your phone.
     
  3. jman995x thread starter macrumors regular

    Joined:
    Sep 8, 2007
    #3
    "iMessages" is turned OFF on my iPhone.
    I'm talking about plain old texts between not only friend's iPhones but also Samsung's, etc. not hitting my phone at all and finding them days later on my "Messages" app on my MBP (which I haven't used for a couple of days).

    I kill the program before I put the computer to sleep, but for some reason when I awaken the computer the "Messages" app is either running in the background, or receives the texts as soon as I boot up the "Messages" program.

    I'm really confused how this could be happening.
     
  4. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #4
    THIS is why it's happening.

    Problem solved. Turn that back on.
     
  5. jman995x thread starter macrumors regular

    Joined:
    Sep 8, 2007
    #5
    I turned it off because my wife and I were seeing every text that each of us sent to all of our friends. I'd send a text to my Mom and my wife would text me asking why I sent that text to her, and vice versa. Literally, any text either of us sent to anybody went to the both of us as well. So, I turned it off.
     
  6. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #6
    That's confusing... "Plain old texts" can't be received by your Mac. It can only receive iMessages, and your friends with Samsungs can't send iMessages from their Samsungs, but they could if they had an iOS device or a Mac.

    You can always try opening the Messages app on your computer, go into Preferences, and then disable the account entirely. Or edit the account so that it doesn't use your iPhone's telephone number to send/receive iMessages.
     
  7. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #7
    Working as intended.

    You wand your wife need separate AppleID's and you need to have iMessage turned on to receive iMessages.
     
  8. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #8
    That's a symptom from being signed into iMessage (on both phones) with the same AppleID. IMO, you guys should have your own unique AppleIDs to sign into iMessage, FaceTime, and iCloud, but you can share a different AppleID (different from your unique ones) to sign into the App Store and iTunes Store (that way you guys don't have to buy apps/music twice, once for each phone).
     
  9. jman995x thread starter macrumors regular

    Joined:
    Sep 8, 2007
    #9
    Ah.

    But that still doesn't explain why I'm not receiving regular text messages from my friends on my iPhone (like I was a shortly as 2 weeks ago), and why "Messages" on my MBP has suddenly started intercepting them (even when I'm not on my computer). I know in the Setting panel for "Messages" on my MBP that there are boxes that state, "I can receive messages here (insert phone number)," and yes I have that checked so that I can receive test messages on my MBP....but WHEN I'M ON MY COMPUTER. It makes no sense for the messages to be held out in cyberspace until the next time I boot my computer. What's the point of that?....why not deliver it to the phone if the computer is off.

    Very frustrating.
     
  10. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #10
    If you have even one device (like your Mac) registered with the iMessage service, then when your friends with iOS devices/Macs go to send you a message, their devices are automatically going to send it as an iMessage, not as text message.

    That's just how the system works.

    The point is that the way that most everyone uses it, iMessages would NOT be turned off on the phone, so the message would appear both on the Mac and the iPhone.
     
  11. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #11
    You claim that people using Samsung phones send you text messages that you don't receive anywhere but on the Messages app on your computer. But text messages (SMS) and iMessage have nothing, nothing at all, to do with each other. The claim that Messages on your computer has started intercepting SMS that are being sent to your phone is as strange as saying you no longer receive voice mails, because they're being intercepted by your email account. Or that you no longer receive emails since you installed a fax machine.

    The only thing that Messages receive is iMessage messages, and these are being delivered to your computer no matter if your computer is turned off or not - the exact same way that emails are being delivered to your computer no matter if it's turned on or not. If you want iMessage messages to be delivered to your phone as well, you have to activate iMessage on your phone.

    So, my guess is you're simply mistaken.
     
  12. viewfly, Nov 27, 2013
    Last edited: Nov 27, 2013

    viewfly macrumors 65816

    viewfly

    Joined:
    May 1, 2009
    #12
    "Messages" app keeps intercepting texts when computer is asleep

    Your friends with Samsung are probably sending SMS to your Apple ID email address (or another registered email), not your phone number. In your Mac you have set to receive them.

    Your friends need to send text to your phone number instead. Yes you can send txt to an email via plain old SMS.

    Your friends think they're sending to a number but it is actually an email. Have them start a new message and manually type in your phone number, not your contact name.

    That would also explain your wife's situation. Read the iMessage instructions a bit more carefully.


    Everything works fine for me and I have 5 Apple Macs , iPads and phones in my family. Everything is separate as desired.
     

Share This Page