Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Cram

macrumors member
Original poster
Mar 27, 2022
56
30
I've just switched from iMac to a MacBook Pro and no new text messages have come through since. I've checked settings and clicked Sync Now, but still nothing. What am I missing?
 

rm5

macrumors 68020
Mar 4, 2022
2,149
2,404
United States
That's a drag!! I've had the same issue before when setting up iMessage on a new Mac. It seems like it always resolves by itself after awhile. Try turning off "Enable Messages in iCloud" and turn it on again. Other than that, sign out and sign in again, and try restarting the machine.

For me, sometimes after just sitting there forever, it says at the bottom left "Downloading Messages from iCloud." And then I just wait.
 

Cram

macrumors member
Original poster
Mar 27, 2022
56
30
That's a drag!! I've had the same issue before when setting up iMessage on a new Mac. It seems like it always resolves by itself after awhile. Try turning off "Enable Messages in iCloud" and turn it on again. Other than that, sign out and sign in again, and try restarting the machine.

For me, sometimes after just sitting there forever, it says at the bottom left "Downloading Messages from iCloud." And then I just wait.
You sir, are a genius! Did as you suggested (other than sign out and reboot) and it updated straight away.

Many thanks
 

Cram

macrumors member
Original poster
Mar 27, 2022
56
30
Unfortunately, it's still happening. For some strange reason, only the better half's texts are coming through.
 

rm5

macrumors 68020
Mar 4, 2022
2,149
2,404
United States
Maybe try what you did yesterday again, and sign out and in again. Worst case scenario is that you will have to delete the affected conversations and then when the person texts you, it will refresh and show all the older messages. Although that is a real pain. You could always go here https://www.apple.com/support/systemstatus/ and make sure all the iCloud systems are online if you are experiencing further issues
 

rm5

macrumors 68020
Mar 4, 2022
2,149
2,404
United States
And I take it you've tried hitting "Sync Now?"

Also, if you scroll up in the "text field," it should load older messages.
 

Cram

macrumors member
Original poster
Mar 27, 2022
56
30
It seems to have a mind of it's own. It's caught up again!
 

Cram

macrumors member
Original poster
Mar 27, 2022
56
30
Of course, what I should've done was go into the settings on my iPhone and turn on Text Message Forwarding for my MBP.

🤦‍♂️
 

rm5

macrumors 68020
Mar 4, 2022
2,149
2,404
United States
Hey, @Cram I actually just out of the blue had the same issue! On my Mac Pro 5,1 that I'm challenging myself to use as a main computer for a week (working well so far). Was just texting someone with a non-iPhone, and they didn't come though! So I did what you said earlier today (text message forwarding), and it works now!
 
  • Like
Reactions: Cram
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.