Messages app refuses to open. Can anyone help?

Discussion in 'OS X Mavericks (10.9)' started by bstine06, Feb 25, 2014.

  1. bstine06 macrumors newbie

    Joined:
    Feb 25, 2014
    #1
    Disclaimer: I'm new here so forgive me if I do something wrong.

    I recently downloaded Mavericks about a month ago and the setup assistant for Mavericks was trying to make me create a new apple ID. Because of this, I force quit the setup assistant and went on with my life. However, I think this may have some negative effects on the way my computer works now because the Messages app does not even show signs of opening. Im actually not even sure what the app looks like. I have however, been getting occasional iMessage notifications in the upper right corner of my screen. As far as I can tell, I can not respond to these messages and I can only view them in the notification box. Here's the error message I've been getting.

    http://imgur.com/2LXQwbi

    [​IMG]

    If I click "show details" I get a lot of code stuff or something that I do not know how to read. I copied and pasted some of the header that I was able to slightly comprehend (notably the "You don't have permission" section towards the bottom). Here are some of the details of the error message:

    —

    Process: Messages [571]
    Path: /Applications/Messages.app/Contents/MacOS/Messages
    Identifier: com.apple.iChat
    Version: 8.0 (4226)
    Build Info: iChat-4226000000000000~3
    Code Type: X86-64 (Native)
    Parent Process: launchd [242]
    Responsible: Messages [571]
    User ID: 501

    Date/Time: 2014-02-25 21:06:41.494 -0500
    OS Version: Mac OS X 10.9.2 (13C64)
    Report Version: 11
    Anonymous UUID: 524CD16F-46B2-D564-943A-32ED3B748FCD


    Crashed Thread: 0 Dispatch queue: com.apple.main-thread

    Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
    Exception Codes: 0x0000000000000001, 0x0000000000000000

    Application Specific Information:
    Sandbox creation failed: You don’t have permission to save the file “Application Support” in the folder “Library”.

    Application Specific Signatures:
    You don?t have permission to save the file ?Application Support? in the folder ?Library?.


    —

    Again, I've never posted here so if my formatting is off I apologize. Just please try to help me out to get the Messages app working. Thanks in advance!:)
     
  2. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #2
    Try creating a temporary user account (System Preferences>Users and Groups), then creating a new user (admin). Log into the user account - if the same problem persists, it's systemwide. If it works, it's your account. Delete and recreate your account (of course, make sure you keep all your data).

    If it's systemwide, download the combo updater for OS X 10.9.2 (which you have, but sometimes the combo updater clears up weird issues) here. Then, do a repair of permissions (Disk Utility>HD>Repair Permissions) and do a full restart.

     
  3. bstine06 thread starter macrumors newbie

    Joined:
    Feb 25, 2014
    #3
    It's my account. The app worked fine on the temp account. Thanks for your help.

    You said to delete and recreate my account but to "make sure you keep all your data." What exactly does deleting an account do? Are there deliberate steps I must take to ensure that my files are safe? Or are my files stored regardless of the my account's existence?
     
  4. KoolAid-Drink, Feb 25, 2014
    Last edited: Feb 25, 2014

    KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #4
    No problem! :)

    So here's what I would recommend:

    a) Move all your important data in your Pictures/Music/Documents/Downloads/Desktop folders (on the main desktop, click 'Go', then 'Go to Folder" - type "~" (without the quotes), enter. You'll be taken to your home folder. Open a new Finder window, type "/" after 'Go to Folder' again. Create a new folder in this directory named "mine" (no quotes) - you'll be asked for your user account password. Just drag everything from "~" to the "mine" folder in "/" (all the folders - Desktop/Pictures/etc).

    Once you're done with that, it's a simple matter of creating a brand new account. Delete the temporary account I instructed you to create, create a new user account with the same name as your user account, but add your middle initial or something that makes it a bit different. (using the exact same name will cause a conflict) Done, restart.

    When asked to sign in, sign in the NEW user account - it'll ask for your Apple ID. Enter it properly this time. Open iMessage to ensure it works. Then delete the original user account and move everything from "/" - "mine" to "~" (move items from individual folders to the folders there, don't replace the actual folders themselves - that'll mess up permissions).

    Sorry this was a bit long and convoluted, but that should work! You may have to re-set up some settings, etc, such as your wallpaper, but that should eliminate the iMessage problem.

    Let me know if you need anything else or need clarification.



    ----------

    And, of course, this goes without saying: do a Time Machine backup! Set it up, if you haven't already. Backup, backup! You just never know!

    (lecture over, haha)
     
  5. bstine06 thread starter macrumors newbie

    Joined:
    Feb 25, 2014
    #5
    Ugh, I can't thank you enough! Not only did I get iMessage working on my laptop, but I also backed up all my files and got the chance to organize my computer by making a new user account.

    Thank you again for your help! People like you make life far less frustrating.


     
  6. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #6
    No problem! :) Comments like that always make me happy! I'm glad I could be of assistance to you. Feel free to post back here if you have any more questions!

     

Share This Page