Messages App won't connect to iMessage

Discussion in 'OS X Mountain Lion (10.8)' started by RichardC300, Jan 13, 2013.

  1. RichardC300 macrumors 65816


    Sep 27, 2012
    Chapel Hill, NC
    This started 2 or 3 weeks ago, but it hasn't seemed to fix itself. I can't login to my iMessage account on the Messages app!


    Attached Files:

  2. Avatarshark macrumors regular

    Sep 22, 2012
    The Digital Frontier
    Have you tried looking in the System Preference to make sure that you have the user information correct? If all else fail, reinstall Mountain Lion.
  3. Graeme43 macrumors 6502a


    Sep 11, 2006
    Great Britain (Glasgow)
    I am plagued with this now even though its been working perfect since 10.8 got released :(
  4. autobahns macrumors newbie

    Aug 30, 2012
    this happened to me awhile back and caused me about an hour of frustration.

    if you haven't fixed it yet, I recommend doing a Finder > Go > Go to Folder > /private/etc/hosts and seeing what you have in there. If you have any clauses blocking verisign servers remove that and save, and restart messages. That fixed it for me.

    Hope that helps!
  5. nyolc8 macrumors regular

    Jul 20, 2012
    my hosts file is completely default and I have the same problem
  6. Chrysaor macrumors 6502

    May 16, 2006
    Recently Apple started requiring serial numbers in the EFI for iMessage to work, which also broke iMessage in hackintoshes (its fixed now though).
    Did you had any motherboard replacements with no serial numbers on it?
  7. Graeme43 macrumors 6502a


    Sep 11, 2006
    Great Britain (Glasgow)
    If I go to about this Mac, my serial shows up there and also in the system profile thing :confused:

    App store works, gamecenter works, icloud works etc but not iMessage :confused:
  8. justinxtreme macrumors newbie


    Dec 7, 2009
    Orlando, FL
    Are any of you using Hackintosh or the Chimera bootloader on your Macs?

    If so either install Clover bootloader (an EFI-based bootloader) or uninstall Chimera.

    If you install Clover bootloader, you will need to get Chameleon Wizard as well to generate a serial number.

    After installing Clover, go into /EFI and open up the config.plist file with TextEdit

    Using Chameleon Wizard generate a 11-or-12 digit serial number for the appropriate SMBIOS and put it in there. Add some random numbers on top of the 11-or-12 digit serial number and make it so it is a 17-digit serial number, Clover uses 17-digit serial numbers.

    A part of my config.plist looks like this so change the part where it has the serial number on it


    This is a fix for those on a Hackintosh or using the Chimera or Chameleon bootloader.

Share This Page