Messages - Automatically Opens w/ Incoming Message

Discussion in 'OS X Mountain Lion (10.8)' started by JTStarkiller, Aug 27, 2012.

  1. JTStarkiller macrumors member

    JTStarkiller

    Joined:
    Aug 30, 2006
    #1
    I have a question regarding Messages. I tried to find an answer and couldn't. Messages keeps opening whenever someone sends me a message. The app will not be open, and will suddenly start and the message comes in, putting me online. Is there a way to stop this? I hate that it just suddenly brings me online. Thanks.
     
  2. Senseotech macrumors 6502a

    Senseotech

    Joined:
    Nov 23, 2009
    Location:
    Wilkesboro, NC
    #2
    I for one would love to know as well. Its highly annoying to get home and find my MBA and desktop both have popped up iMessages, all because someone sent me one to the right address to hit all my devices. I can only see it getting worse when 10.8.2 comes and we can tie phone numbers to iMessages on the Mac side.
     
  3. westonm macrumors member

    Joined:
    Jun 19, 2007
    #3
    In my experience this only happens on machines that previously had the Messages beta installed, and didn't clean install to 10.8.

    That said I don't have a solution outside of clean install. :/ One hopes Apple will fix the issue in a coming point release.
     
  4. Senseotech macrumors 6502a

    Senseotech

    Joined:
    Nov 23, 2009
    Location:
    Wilkesboro, NC
    #4
    Considering this happens on both my machines that are clean installs of 10.8, I don't think thats the issue.
     
  5. JTStarkiller thread starter macrumors member

    JTStarkiller

    Joined:
    Aug 30, 2006
    #5
    I guess I should clarify that I'm using my GoogleTalk account, not iMessage between Apple devices. The program will just boot up out of nowhere and put me online. I didn't have any kind of beta and did a clean install of Mountain Lion.
     
  6. Senseotech macrumors 6502a

    Senseotech

    Joined:
    Nov 23, 2009
    Location:
    Wilkesboro, NC
    #6
    Hmm, perhaps thats actually the cause of my problems... I don't have a GTalk account, but have a Facebook Chat account set up as Jabber (GTalk is really just Jabber). I may turn off the account and see where that leaves me.
     
  7. natd1993 macrumors regular

    natd1993

    Joined:
    Jul 6, 2011
    Location:
    UK
    #7
    OP, I had the same problem and tried loads of different things to find a fix. I eventually resorted to turning off the 'Message Received' alert for the Messages app, and this seemed to solve my problem. See the image for my exact settings.

    [​IMG]

    EDIT: Note if you're running 10.8 with NC enabled, turning off THIS alert (within the messages app) shouldn't make much difference, as NC has its own for incoming messages.
     
  8. Senseotech macrumors 6502a

    Senseotech

    Joined:
    Nov 23, 2009
    Location:
    Wilkesboro, NC
    #8
    To maybe help someone else out, I can confirm that removing my Facebook Chat account, along with any other Jabber accounts, has cleared up the problem completely on my end. Not sure if it'll help anyone else or why it worked, but it may be worth a try.
     
  9. TGD macrumors newbie

    Joined:
    Nov 13, 2003
    Location:
    Durham, North Carolina
    #9
    "Fix" for AIM accounts

    I've had the same problem, though in my case with AIM and iOS messages coming in to my email address.

    The solution I've found as far as AIM goes is the "Sign out of AIM Buddy List" option under the "Messages" menu. That then triggers the AIM Mobile forwarding I had configured with my mobile phone.

    No luck on stopping incoming iOS messages though, unless I uncheck the "Enable this Account" option in preferences...
     
  10. shaun3000 macrumors newbie

    Joined:
    Dec 2, 2006
    #10
    Solution

    From: https://discussions.apple.com/thread/4422373?tstart=60
     
  11. fdot macrumors regular

    Joined:
    Feb 2, 2008
    #11
    unchecking makes no difference on my machines
     
  12. tomasmcm macrumors newbie

    Joined:
    May 7, 2013
    #12

Share This Page