Messages don't sync anymore

Discussion in 'iOS 11' started by StarShot, Apr 17, 2018.

  1. StarShot macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #1
    Last year when I would get a text message, it would sync on all my Apple devices (MBA, iPad and iPhone). Now when I get a text, which ever device I open, the text appears, but doesn't sync to the other devices.

    I liked the sync routine because all the Text threads are repeated so that I see the complete thread on all of them. Is there a setting to go back to that routine or did upgrades to iOS get rid of it?

    Thanks
     
  2. BugeyeSTI macrumors 68020

    BugeyeSTI

    Joined:
    Aug 19, 2017
    Location:
    Arizona
    #2
    Sign out and back into iMessage.. My devices all synch no issues
     
  3. Kognito macrumors regular

    Kognito

    Joined:
    Jul 27, 2011
    #3
    To add to what has already been suggested, make sure you've got text message forwarding enabled on your iPhone for all relevant devices.

    11.4 will (hopefully) bring Messages in iCloud which actively syncs messages via iCloud rather than just forwarding received messages on to your other devices - so if nothing else, you'll be able to switch over to the new system shortly.
     
  4. az431 macrumors 6502a

    az431

    Joined:
    Sep 13, 2008
    Location:
    Portland, OR
    #4
    That's not sync, it's text message forwarding.
     
  5. StarShot thread starter macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #5
    Where do I find "text message forwarding"?
     
  6. StarShot thread starter macrumors 6502a

    StarShot

    Joined:
    Mar 31, 2014
    #7
    My Messages page didn't look like yours in that there was no "message forwarding" or "Send and Receive".

    I don't remember what I clicked on this menu, but a page then jumped up asking me to sign into iTunes (I think). I signed in with my iTunes password and after a delay, I suddenly got the options you have to popup.

    Guess I'm good to go!!! I must have done something a way back that turned this feature off.
     

Share This Page