Messages has stopped syncing between iPhone and iPad/Mac

Discussion in 'iOS 10' started by Cave Man, Mar 25, 2017.

  1. Cave Man macrumors 604

    Cave Man

    #1
    I changed my iCloud password a couple of days ago and now Messages is no longer syncing correctly. My MacBook Air and iPad Pro are synced, but not my iPhone. And my Mac Mini now only sends SMS (green) not iMessage. I have looked for the solution on the google but none seem to work, including signing out and signing back in, or powering off the iPhone and iPad. What's peculiar is that if I send a message from my iPhone to my son, it shows up as "Dad" (his contact name for me); however, from my computer or iPad it shows up as being from my email address that is associated with my Apple ID. Sending from my Mac Mini now attempts to send an SMS but it fails to go through. Any ideas what is going on? This is really frustrating.
     
  2. sundog925 macrumors 6502a

    Joined:
    Dec 19, 2011
    #2
    do you have two factor authentication enabled? If so, you have to sign into your apple ID on the web and generate a password for the iMessage app on your mac.
     
  3. Alrescha, Mar 25, 2017
    Last edited: Mar 26, 2017

    Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    I have two-factor authentication enabled and I have not generated any application-specific passwords. Messages has always synced fine across my iOS and macOS devices.

    If you need to generate an app-specific password for an Apple application, that is an indication that something else is wrong. If it were me, I would sign out of iCloud on all the affected devices and sign back in.

    A.

    addendum:

    Do not sign out of iCloud on all of your devices at the same time - you will have a hard time getting signed back in if you do.
     
  4. Cave Man thread starter macrumors 604

    Cave Man

    #4
    That did it. I had to sign out one at a time, then sign back in. This seems like something Apple should address.
     

Share This Page