Messages in iCloud Beta 4

greg624

macrumors regular
Original poster
Jul 31, 2013
197
117
Indiana
So now the setting doesn't appear at all in beta 4, but in iCloud settings. Can someone tell me if messages in iCloud still works and sync's with their Mac? It worked in other betas for me.
 
  • Like
Reactions: Donfor39

Ptitfredd

macrumors newbie
Jul 26, 2017
7
0
I’ve just decided to install iOS 11 PB 3 on my 7+ and iPads, and messages in iCloud doesn’t work for me.
Though everything is checked in settings, it keeps on indicating « syncing XXX messages with iCloud » and then « sync finished » a few seconds later... But nothing is in the cloud.

Same on my iMac, I don’t know if the feature doesn’t work, or if that’s a problem with my account ?
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
I’ve just decided to install iOS 11 PB 3 on my 7+ and iPads, and messages in iCloud doesn’t work for me.
Though everything is checked in settings, it keeps on indicating « syncing XXX messages with iCloud » and then « sync finished » a few seconds later... But nothing is in the cloud.

Same on my iMac, I don’t know if the feature doesn’t work, or if that’s a problem with my account ?
What do you mean "nothing is in the cloud"?
 

Ptitfredd

macrumors newbie
Jul 26, 2017
7
0
I mean that the sync immediatly stops, and in settings it’s indicated « last sync : never ».
Messages are not syncronized between my devices, and in iCloud storage, no indication about messages saved (my conversation are about 2 Go on my devices).
 

Mlrollin91

macrumors G5
Nov 20, 2008
13,528
9,078
Ventura County
I mean that the sync immediatly stops, and in settings it’s indicated « last sync : never ».
Messages are not syncronized between my devices, and in iCloud storage, no indication about messages saved (my conversation are about 2 Go on my devices).
Do you have 2FA enabled? Have you tried restarting your device or signing out of iCloud and then back in? I'm not currently running the beta so I cannot say if it works or not. I'm just giving troubleshooting steps.
 

greg624

macrumors regular
Original poster
Jul 31, 2013
197
117
Indiana
Actually it just starting syncing automatically after I synced on my Mac. It seems to be working just fine now on Beta 4.
 

Ghivi01

macrumors newbie
Jul 26, 2017
9
4
I had to activate 2FA but I was finally able to have Message on iCloud on in both my Macbook and iPhone. The messages have been copies to the cloud since I can see when I manage my iCloud storage. There seems to be something wrong though. The chats I have in my Mac and iPhone are to the same. When I delete a chat in my iPhone, the same chat is not deleted from my Mac. I thought that was the idea. Am I getting it wrong?
 

Ghivi01

macrumors newbie
Jul 26, 2017
9
4
I had to activate 2FA but I was finally able to have Message on iCloud on in both my Macbook and iPhone. The messages have been copies to the cloud since I can see when I manage my iCloud storage. There seems to be something wrong though. The chats I have in my Mac and iPhone are to the same. When I delete a chat in my iPhone, the same chat is not deleted from my Mac. I thought that was the idea. Am I getting it wrong?
Problem solved by itself. Today it started to sync correctly between macOS High Sierra and IOS 11.
 

hArrisburger

macrumors regular
Jul 1, 2013
154
26
I’ve just decided to install iOS 11 PB 3 on my 7+ and iPads, and messages in iCloud doesn’t work for me.
Though everything is checked in settings, it keeps on indicating « syncing XXX messages with iCloud » and then « sync finished » a few seconds later... But nothing is in the cloud.

Same on my iMac, I don’t know if the feature doesn’t work, or if that’s a problem with my account ?
Same issue here and I do have have two factor authentication.
 

gsmornot

macrumors 68040
Sep 29, 2014
3,226
2,783
I thought that the messages were supposed to sync between devices as well. I haven't been able to get that working. Has anyone?
Works here between MAC, iPhone, and iPad. Sync takes place at least once per day. The only catch I have at the moment is the need to quit and start again on my MAC so the 30 day delete will occur. If I leave the app open (I do) it will retain messages no matter how old but it does still sync.
 

DNichter

macrumors G3
Apr 27, 2015
8,961
10,075
Philadelphia, PA
Works here between MAC, iPhone, and iPad. Sync takes place at least once per day. The only catch I have at the moment is the need to quit and start again on my MAC so the 30 day delete will occur. If I leave the app open (I do) it will retain messages no matter how old but it does still sync.
Hmm, doesn't seem to be working for me between iPhone and iPad. I delete a message on my iPhone and it remains on my iPad when I get home from work. Maybe it's timing, but it should just work automatically like all of the other Apple cloud services.
 

hArrisburger

macrumors regular
Jul 1, 2013
154
26
I just did a restore from new and iMessages are slowly syncing, but it doesn't appear that pictures or gifs within message threads are syncing. Those that have gotten it to work, have you noticed the same?
 

lsutigerfan1976

macrumors 68030
Sep 14, 2012
2,547
1,547
I just did a restore from new and iMessages are slowly syncing, but it doesn't appear that pictures or gifs within message threads are syncing. Those that have gotten it to work, have you noticed the same?
Hmm... I tried everything including this, and mine still won’t sync. I feel like I am missing something I am not doing.
 

Donfor39

macrumors 68000
Jul 26, 2012
1,627
242
Lanarkshire Scotland
What do you mean "nothing is in the cloud"?
I did previously have save messages in cloud option on.pb 2

Seems it’s since removed from pb 3

Minor irritation not having this option on my brand new 10.5 iPad Pro

Thankfully my data plan was enabled yesterday evening as I tried in vain to enable data plan by inserting another sim which worked instantly achieving 30mb 4g data d/load 10mb u/load .

I’ll ask again is there any other mser’s found save messages to iCloud option removed since ios11 pb3
 

hArrisburger

macrumors regular
Jul 1, 2013
154
26
I did previously have save messages in cloud option on.pb 2

Seems it’s since removed from pb 3

Minor irritation not having this option on my brand new 10.5 iPad Pro

Thankfully my data plan was enabled yesterday evening as I tried in vain to enable data plan by inserting another sim which worked instantly achieving 30mb 4g data d/load 10mb u/load .

I’ll ask again is there any other mser’s found save messages to iCloud option removed since ios11 pb3
Yes, I got it to work. Now, pictures and gifs embedded in messages did not come through, but texts as far back as 2007 transferred over. There were some issues (I got notifications for old texts or texts I had quickly deleted as far back as years ago reappeared), but it did work.
 

doubletap

macrumors regular
Jan 2, 2009
163
36
Ashburn, VA
I did previously have save messages in cloud option on.pb 2

Seems it’s since removed from pb 3

Minor irritation not having this option on my brand new 10.5 iPad Pro

Thankfully my data plan was enabled yesterday evening as I tried in vain to enable data plan by inserting another sim which worked instantly achieving 30mb 4g data d/load 10mb u/load .

I’ll ask again is there any other mser’s found save messages to iCloud option removed since ios11 pb3
I have the Sync Now option in Settings - Messages.

Even though it synced as of last night, messages from yesterday are missing on my Mac. Very odd.

EDIT: And just like that, Messages on iOS just synced and shows today's date and time. Those missing messages are now on my Mac. I guess the solution is to post that you're having the issue and then it gets resolved. :)
 
Last edited:
  • Like
Reactions: Donfor39

Donfor39

macrumors 68000
Jul 26, 2012
1,627
242
Lanarkshire Scotland
Since found as recently suggested messages under iCloud settings saved as part of iCloud backs

Though as iCloud Drive is no longer on iPad replaced via files I have no way of visually seeing if texts are being stored
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.