Messages in iCloud not syncing

c14nhl

macrumors 6502
Original poster
Oct 30, 2008
436
150
Edinburgh
I downloaded 11.4 on both my iPhone X & iPad Pro 9.7 immediately. Straight away turning Messages in iCloud on on both devices.

They have never synced. I feel like both are stuck in some way.

I get the attached pop up when attempting to turn off and therefore have never done so.

Has anyone else seen this? Any advice?
 

Attachments

funandblindness

macrumors member
Jul 18, 2002
46
27
Oregon
I downloaded 11.4 on both my iPhone X & iPad Pro 9.7 immediately. Straight away turning Messages in iCloud on on both devices.

They have never synced. I feel like both are stuck in some way.

I get the attached pop up when attempting to turn off and therefore have never done so.

Has anyone else seen this? Any advice?
I did disable and download, reset on each device and it works now. Didn't have many messages, none critical.
 

iKaushal

macrumors 6502
Jun 7, 2011
444
48
Mumbai, India
Mine was working till last night.

Today all of a sudden the latest messages which I got on my iPhone are not synced with my ipad or macs
 

Beards

macrumors 6502a
Mar 22, 2014
941
379
Derbyshire UK
Mine have been syncing between devices prior to 11.4 perfectly fine and that's without iMessages in iCloud.
So why is it suddenly different?


To be honest I can't see the reason why I should change when it's working just fine at the mo.
 

BeatCrazy

macrumors 68000
Jul 20, 2011
1,934
797
I'm having issues here, too.

If I delete on MacBook, it doesn't delete on my iPhone.
If I delete on iPhone, it does delete on the MacBook.

What would cause that?
 
  • Like
Reactions: NowhereManNumber9

c14nhl

macrumors 6502
Original poster
Oct 30, 2008
436
150
Edinburgh
I’ve disabled on both devices.

I was hoping to restart the whole process but Apple give you 30 days to undo the disable so instead of restarting the process it just enables in the state it previously was, which is in some way stuck.

Looks like I'll be leaving off for 30 days!
 

Cmd-Z

macrumors 6502
Nov 14, 2014
478
504
Coyote, CA
Mine have been syncing between devices prior to 11.4 perfectly fine and that's without iMessages in iCloud.
So why is it suddenly different?
If you look closely, prior to 11.4 things are not in sync when you delete a message from a device -- it would not be deleted on the others. For example, if I get a temporary authorization code messaged to me, normally I'd delete the message when done but would have to do that to all my devices. Now it's one-and-done.
[doublepost=1528231630][/doublepost]
I'm having issues here, too.

If I delete on MacBook, it doesn't delete on my iPhone.
If I delete on iPhone, it does delete on the MacBook.

What would cause that?
Did you enable this feature on the Mac? It is not ON by default, and turning it on is not so evident. You have to open Messages, then open Preferences/Accounts and there you'll see the setting for Messages in iCloud -- you will not find it in iCloud settings on the Mac for some stupid reason.
 
  • Like
Reactions: Beards

BeatCrazy

macrumors 68000
Jul 20, 2011
1,934
797
Did you enable this feature on the Mac? It is not ON by default, and turning it on is not so evident. You have to open Messages, then open Preferences/Accounts and there you'll see the setting for Messages in iCloud -- you will not find it in iCloud settings on the Mac for some stupid reason.
Yes, I absolutely enabled it in the manner described. I even turned it on/off a few times. I couldn't seem to log all the way out of iCloud, but I was trying that too.
 

doxielover

macrumors 6502a
Apr 12, 2011
855
101
CA
All my current devices get text forwarding iMessage by send and receive from my phone number. If I update my Mac and my other iOS devices to 11.4 will I lose the option getting my messages on all my devices?

I know it has the new iCloud sync messages but I don’t have enough space left and I don’t want to buy more. I just want to make sure I don’t lose the way that I get them on all my devices now.
 

appleunderpants

macrumors newbie
Feb 25, 2016
13
34
Started clean on my iPhone and Mac and only getting about 80% of my messages synced between the two devices. Entire conversations missing on my Mac, while other conversations are present but most of the messages aren't there.

I've kept text message forwarding active and have turned iCloud Messages off and on a couple of times. It's kind of a joke at this point...
 

Cmd-Z

macrumors 6502
Nov 14, 2014
478
504
Coyote, CA
Yes, I absolutely enabled it in the manner described. I even turned it on/off a few times. I couldn't seem to log all the way out of iCloud, but I was trying that too.
Two suggestions then:
1- Ensure that 2FA security is enabled on your account.
2- Go into your Mac's preferences in the Message app again, and on the General tab de-select "Save history when conversations are closed." (this seems to mess up iCloud Messages sync)
 
  • Like
Reactions: BeatCrazy

BeatCrazy

macrumors 68000
Jul 20, 2011
1,934
797
Two suggestions then:
1- Ensure that 2FA security is enabled on your account.
2- Go into your Mac's preferences in the Message app again, and on the General tab de-select "Save history when conversations are closed." (this seems to mess up iCloud Messages sync)
Wow it looks like that worked! I already had/used 2FA. But the "Save history" selection was something I was unfamiliar with. Looks like when it is selected, messages in your Mac's history are pushed back into iCloud, causing the sync problems.
 

silvertech

macrumors member
May 30, 2016
41
19
I am having this same problem with mine, after about a day. In iCloud settings it says Zero KB which is clearly not true as it says I also have 14gbs of Messages. All my old messages from my Mac have still not synced to my iPhone and vice versa. When I go to turn it off I get the same popup. Tho the 'Downloading messages to/from iCloud is no longer there anymore.
 

GDF

macrumors 6502a
Jun 7, 2010
580
292
Same problem for me too on ipad and iPhone X. Messages were synching perfectly until a couple days ago. Can't figure out what changed.
 

dtobin95

macrumors newbie
Aug 17, 2019
1
0
I’ve disabled on both devices.

I was hoping to restart the whole process but Apple give you 30 days to undo the disable so instead of restarting the process it just enables in the state it previously was, which is in some way stuck.

Looks like I'll be leaving off for 30 days!
Did the sync process work again after 30 days?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.