Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

tardman91

macrumors 65816
Original poster
Oct 21, 2009
1,090
219
Tampa Area, FL
I just setup my new M1 MacBook Air and my messages app isn't showing my contact's names in the notifications (in the top right) when I get a message. It just shows the phone number. When I open the app to read/reply it shows the contact's names. Does anyone know how I can fix it so that I also see the names in the notifications instead of just the phone numbers? I'm all up to date on everything.
 

tardman91

macrumors 65816
Original poster
Oct 21, 2009
1,090
219
Tampa Area, FL
It’s been doing this since yesterday. All of my contacts are synced. I see their names when I open up messages, just not in the pop up notifications that I get. I don’t know if I missed a setting or something?
 

rillrill

macrumors 6502a
Jul 27, 2011
740
490
New York
Bump. Anyone still have this problem? When texts come in, it's the phone number instead of the name....annoying as hell.
 

Peadogie

macrumors regular
Aug 4, 2019
223
144
Georgia, USA
I installed 10.0.1 on 11/16 and it displayed names as expected until yesterday when it started showing numbers.
Strangely, sometimes the notification also has the phone number and "Maybe: Senders Name". It is often a wrong guess. o_O
As @tardman91 noted it shows names and pictures correctly in the messages.
 
Last edited:
  • Like
Reactions: tardman91

marzfreerider

macrumors 6502
Jun 13, 2014
333
208
Canada
It's been showing phone numbers since the beta stages, not looking good for a fix anytime soon. I reported it a few times as well.
 

Howard Ellacott

macrumors regular
Jun 10, 2012
186
129
United Kingdom
Are you switching users? I find names work fine until I log in as another user. As soon as I switch back it only shows numbers. Happens 100% of the time. Feedback assistant shows that other people have also logged this as an issue!
 
  • Like
Reactions: Peadogie

MacGizmo

macrumors 68020
Apr 27, 2003
2,100
1,346
Arizona
Are you switching users? I find names work fine until I log in as another user. As soon as I switch back it only shows numbers. Happens 100% of the time. Feedback assistant shows that other people have also logged this as an issue!
Having the same issue – but I only have one user account on the Mac, so that's probably not the/my problem. Count me as one of those people who've sent it in via Feedback Assistant.
 
  • Like
Reactions: Peadogie

mikzn

macrumors 68030
Sep 2, 2013
2,969
2,232
North Vancouver
Wow - seems like quite a few PPL with this issue - strangely (and luckily ?) it works properly for me version 11.1 Beta (20C5061b) and has worked fine all the way thru Catalina and all of the Big Sur betas - FWIW

Knocking on wood here - I use messages (for staying in touch with clients) a lot and this would be very inconvenient to say the least if it suddenly happened on my Big Sur / MBP
 

michaelafcadio

macrumors member
Apr 21, 2019
49
3
Boston, MA
Is anyone aware of a good comprehensive guide/resource on steps to go through to get this working again?

I've had this problem for years and it continues. I've never been able to pin it down to doing anything specific. Typically going through all the magic incarnations of signing in and out of iCloud, enabling and disabling iMessage, device restarts, updates, and resets eventually gets this working again. Until it stops working again in a few months. I've seen this on both iPhones and Macs over the years. Sometimes my MacBook shows names and my iMac does not. Sometimes both show names, sometimes neither. Like much of Apple's ecosystem, it's easy and works great... until it doesn't.
 

stevenaaus

macrumors member
Oct 23, 2013
52
37
Maybe related to iCloud repsonse times.... ?
Gotta say, how could they scr*w up something simple like this.
Answer - contacting busy/borked remote servers when they shouldn't be.
which is dfinitely the cause of their sloth-like app launches. Their whole OS design has gone to the dogs. Your computer should be as self reliant as possible.
 
  • Like
Reactions: Peadogie

tardman91

macrumors 65816
Original poster
Oct 21, 2009
1,090
219
Tampa Area, FL
It always worked fine for me on my 2018 MacBook Air, which I always kept up to date, even with Big Sur. I didn’t have this issue until I bought a new M1 MacBook Air.
 
  • Like
Reactions: stevenaaus

Peadogie

macrumors regular
Aug 4, 2019
223
144
Georgia, USA
Well, I rebooted and now the notifications are showing names again, but now auto capitalization and "Touch Bar typing suggestions" are gone. Geez.
Feedback reported to Apple.
 
Last edited:

vetdocjim

macrumors newbie
Jan 9, 2021
9
2
I have the same issue with names and numbers in messages. If you restart it will resolve. If you switch users or logout and login without restart the bug will return. 100% of time. Only affects the Macbook pro messages, not iOS14 on phone or ipad. Senior engineers have been updated and they have code dumps since I have been working with them. Rather annoying. All the usual tricks on the local devices fail to resolve (except restart, or zapping PRAM also works). If you keep the machine sleeping and allow it to go into password mode, when you wake it up and enter pass the problem does not appear. I think we all suspect it is an issue on Apple's servers/icloud end. This problem appeared for me with Bigsur11.1 and iOS14.x. updates are up to date and there has been no resolution. I have not heard from Apply in a few weeks regarding anything definitive. Only updated that they "have thousands of lines of code" to review to track this down. Anybody here have additional information?
 
  • Like
Reactions: Peadogie

IAmTheCrack

macrumors member
Mar 25, 2009
54
3
FOLLOWING. I'm having this issue on my M1 MacBook Pro as well. Thought it was just me. Incredibly frustrating.
 

rezafactor

macrumors newbie
Jan 16, 2021
1
0
Created an account just to say I am also having this issue on a 2019 MBP 16. Tried literally everything, and managed to fix it for a bit, but it came back. I have two user accounts but have not been able to narrow anything down.
 

vetdocjim

macrumors newbie
Jan 9, 2021
9
2
Apple contacted me again. Engineers so far cannot isolate the problem. Sometimes backing up Contacts manually to iCloud worked. But that was inconsistent. A restart always resolves it until you literally logout and in. Restart or shutdown and start always fixes!
 
  • Like
Reactions: Peadogie
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.