Messages notification bug

Discussion in 'iOS 7' started by josiahsill, Aug 1, 2013.

  1. josiahsill, Aug 1, 2013
    Last edited: Aug 2, 2013

    josiahsill macrumors member

    josiahsill

    Joined:
    Jun 10, 2011
    Location:
    Memphis, TN
    #1
    Don't know if this has been brought up yet for beta 4 but while using an app (safari, a game, settings, whatever) I won't get a notification from messages. When I close out of using whatever app I'm using I'll see the badge icon over my messages icon and then read the message. If the phone is locked or just sitting on the homescreen however I will get the notification. Anybody else have this issue. I think it was around in beta 2&3 but I'm not sure. Any fixes? I've tried resetting all settings and stuff but to no avail.

    UPDATE:

    So i figured out a (not so nice but usable) workaround for this bug.
    I changed the notification type to alert instead of banner and I haven't missed a text yet now.
     
  2. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #2
    So glad I'm not the only one that notices this. I don't even think it sounds or vibrates when using the phone. It's a rather annoying bug. Think it was the same in the last beta.
     
  3. aDRock1154 macrumors 65816

    aDRock1154

    Joined:
    Nov 15, 2011
    Location:
    Ohio
    #3
    I too have been affected with this bug. It happened last night. My wife was like "are you gonna answer any of my texts?" I looked and I had 8 new messages.

    Then, I got some sort of "provisioning profile" that wanted to install. It had something to do with Verizon, but I hit cancel.

    Weird stuff huh?
     
  4. Daveoc64 macrumors 601

    Joined:
    Jan 16, 2008
    Location:
    Bristol, UK
    #4
    I thought there was a bug like this in one of the previous betas (Beta 2?), then it was supposedly fixed.

    It's happening again for me in Beta 4 now.
     
  5. josiahsill thread starter macrumors member

    josiahsill

    Joined:
    Jun 10, 2011
    Location:
    Memphis, TN
    #5
    I've had it for at least betas 3-4 now.
     
  6. jeremiah239 macrumors 6502a

    jeremiah239

    Joined:
    Nov 1, 2007
    Location:
    239 Area, FL
    #6
    Yeah this has happened to me on b3 and still on b4. Hope it's fixed in b5! :)
     
  7. bbfc macrumors 68030

    bbfc

    Joined:
    Oct 22, 2011
    Location:
    Newcastle, England.
    #7
    This is actually quite annoying. I was on twitter on my mac and a friend tweeted me to ask if I had received any of her texts - i checked and I had 3 messages. I was playing music through my dock but hadn't locked the phone so the notifications didn't even appear or sound. I even set Messages to the old style popup message and they still didn't appear. I think it's happening with ALL notifications.

    Definitely a bug.
     
  8. fivedots macrumors 6502a

    Joined:
    Jun 29, 2011
    #8
    Not sure if related and can't test further as I'm back on iOS 6, but I was having a heck of a time getting notifications from Reminders as well. They'd be in the Notification Center but not produce a sound or a pop-up.
     
  9. TheKrs1 macrumors 6502

    Joined:
    Apr 11, 2010
    #9
    I have the issue for mail notifications as well. It appears to happen after 2-3 days of usage without a reboot. I find a hard reset fixes the issue until it crops up in a few days time.
     
  10. bgro macrumors 6502a

    Joined:
    Jul 6, 2010
    Location:
    South Florida
  11. bamafever09 macrumors regular

    bamafever09

    Joined:
    Aug 6, 2008
    Location:
    Hoover/Tuscaloosa Alabama
    #11
    I have had it since the first beta. I have submitted a bug report with every new beta so I think they know about it. Hopefully it will be fixed in beta 5.
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    Yeah, sporadic notifications and the way they appear in the notification center (locked vs. unlocked) has been an issue for at least the last couple of betas it seems.
     
  13. pmontanarella macrumors 6502

    Joined:
    Oct 12, 2012
    Location:
    Rio de Janeiro, Brazil
    #13
    Happening for me as well, quite an annoying bug. Will submit bug report.

    Pietro
     

Share This Page